HELP! Truck keeps running after ignition is turned off - Chevrolet Colorado & GMC Canyon Forum
Chevrolet Colorado & GMC Canyon Forum
 
Go Back   Chevrolet Colorado & GMC Canyon Forum > Tech Area > Aesthetics > Electrical/Lighting/Security

355Nation.net is the premier Chevrolet Colorado Forum on the internet. Registered Users do not see the above ads.
User Tag List

Reply
 
LinkBack (1) Thread Tools Search this Thread Display Modes
Old 08-23-2009, 03:05 PM   1 links from elsewhere to this Post. Click to view. #1
Nation Affiliate
 
Join Date: Jun 2008
Location: Frisco, Texas
Posts: 234
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via AIM to consti2tion
HELP! Truck keeps running after ignition is turned off

Okay so this started about a week ago.

I turn my truck off and the engine keeps running after the key is removed. The gauges all die down and the A/C turn off but the engine keeps running, until I open and close the door then it will turn off. My outside temp. and compass stay on ALL of the time now unless I unplug the harness. I cannot figure this out for the life of me. I removed the whole fuse panel looking for maybe a short or something and nothing is wrong with it.

I can't find anything in the forum relating to this.
__________________
consti2tion is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-23-2009, 03:23 PM   #2
Its too hot in Texas!

Military Service TOTM Winner Nation Elite OG Lifetime Contributing Member How-To CM SuperMeet Organizer Public Service Calendar Spread 355 Celebrity TXSM 10 

 
Stealth_Canyon's Avatar
 
Join Date: Apr 2009
Location: Sealy, TX
Posts: 6,472
Mentioned: 0 Post(s)
Tagged: 2 Thread(s)
Send a message via Yahoo to Stealth_Canyon
Re: HELP! Truck keeps running after ignition is turned off

Dude I would take it to the dealership!! that is crazy
__________________
Its like a really good fart, if you want to keep it then you need to squeeze tight!

Rest in Peace Forrest. You truely were a great friend and will be deeply missed!
Stealth_Canyon is offline   Reply With Quote
Old 08-23-2009, 03:35 PM   #3
Premium Member

Calendar Spread 

 
Low_S-10's Avatar
 
Join Date: Nov 2008
Location: Fort Worth
Posts: 659
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Re: HELP! Truck keeps running after ignition is turned off

yea take it to the dealer, the only think i can think of would be maybe the BCM is bad and getting signals mixed up with the retained accessory power(RAP) and thats would be why it stays on till a door is opened
__________________
2014 Chevy Silverado Crew Cab Z71 - Daily Driver
2013 Chevy Silverado Crew Cab Texas Edition - SOLD
2009 Chevy Colorado extended cab ZQ8 5.3l - SOLD
2003 Chevy S-10 extended 4.3l bagged on 20" IROC - SOLD
1970 Chevy Suburban 3 Door - Project in the back yard rotting away
Low_S-10 is offline   Reply With Quote
Old 08-23-2009, 05:18 PM   #4
Nation Affiliate
 
Join Date: Jun 2008
Location: Frisco, Texas
Posts: 234
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via AIM to consti2tion
Re: HELP! Truck keeps running after ignition is turned off

I fixed it, there was a short between the CC fuse and the Heated Seat fuse. I didn't think it would be the BCM, since it's been replaced 2 times since I've had the truck. Thanks for the input guys.
__________________
consti2tion is offline   Reply With Quote
Old 11-24-2010, 04:33 PM   #5
Nation Citizen

355 O.G. Contributing Member 355 Celebrity 

 
khkustoms's Avatar
 
Join Date: May 2007
Location: Tucson Az
Posts: 1,000
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: HELP! Truck keeps running after ignition is turned off

Hey how did u find the short? My trucks doing the same damn thing!!
khkustoms is offline   Reply With Quote
Old 11-24-2010, 06:05 PM   #6
Nation Elite

355 O.G. Nation Elite Contributing Member How-To CM 355Loyalty NESM 11 

 
lkout4trucks's Avatar
 
Join Date: Apr 2007
Location: NH
Posts: 3,617
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: HELP! Truck keeps running after ignition is turned off

thats a new one! man the electrical nonsense these trucks pull is insane!
__________________

05 Chevy Canyon (no I'm not stating the name wrong) - Traded In, apparently never to be seen again...
08 Trailblazer SS awd - the new hawtness.

Northeast members be sure to check out our local site: www.NEC355.net
lkout4trucks is offline   Reply With Quote
Old 11-24-2010, 08:10 PM   #7
Nation Citizen

355 O.G. Contributing Member 355 Celebrity 

 
khkustoms's Avatar
 
Join Date: May 2007
Location: Tucson Az
Posts: 1,000
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: HELP! Truck keeps running after ignition is turned off

Well that consti2ution guy said his dis the same thing just trying to figure out how he figured it out...
khkustoms is offline   Reply With Quote
Old 11-30-2010, 11:48 AM   #8
New To The Nation
 
Join Date: May 2010
Location: Winston-Salem,NC
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: HELP! Truck keeps running after ignition is turned off

Mine did that when I installed an electric fan and tried to wire the fan to a RAP fuse. I would only do it when the A/C was on. Ended up just wiring the ignition control wire for the control box to the battery.
holderp is offline   Reply With Quote
Old 12-03-2010, 10:19 PM   #9
Mini Trucker for Life

Lifetime Contributing Member MESM 10 MESM 11 

 
Lug nut's Avatar
 
Join Date: Aug 2008
Location: Illinois
Posts: 312
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage
Send a message via Yahoo to Lug nut
Re: HELP! Truck keeps running after ignition is turned off

mine dose that when its hot out but all i do is turn the key back on then off and it shuts off. think mine is an ignition switch
__________________
Lug nut is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


LinkBacks (?)
LinkBack to this Thread: http://www.355nation.net/forum/electrical-lighting-security/21259-help-truck-keeps-running-after-ignition-turned-off.html
Posted By For Type Date
My 06 canyon runs after u take the key out!! - MiniTruckin General This thread Refback 01-10-2014 10:27 AM


All times are GMT -4. The time now is 09:48 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
User Alert System provided by Advanced User Tagging v3.0.6 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
All content copyright 355Nation.net

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.3.0