Failed inspection. No reading from obd2. Help please - Chevrolet Colorado & GMC Canyon Forum
Chevrolet Colorado & GMC Canyon Forum  
Go Back   Chevrolet Colorado & GMC Canyon Forum > Tech Area > Aesthetics > Electrical/Lighting/Security

355Nation.net is the premier Chevrolet Colorado Forum on the internet. Registered Users do not see the above ads.
User Tag List

Reply
 
LinkBack (1) Thread Tools Search this Thread Display Modes
Old 10-18-2009, 05:57 PM   1 links from elsewhere to this Post. Click to view. #1
New To The Nation
 
Join Date: Oct 2007
Location: Albany, Louisiana
Posts: 69
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Failed inspection. No reading from obd2. Help please

So, I went to get an inspection sticker and their machine could not get a reading from my obd2. They told me that this is usually from a blown cigarette lighter fuse. So I checked both fuses, and tested both cigarette lighters and everything is good. I haven't had any issues with my truck. And I just took a test light to every fuse and everything is receiving power. I have been looking around for a loose wire or bent pin but I don't see any problems. There are 4 wires hooked into the plug. They are: orange, black/white striped, black, purple. I got the dmm and the orange is the 12v (it was reading at the plug), and it appeared that all the other wires were ground. I left the positive lead from the dmm touching the Orange and touched the negative lead on each of the remaining 3 wires and got a 12+ reading.
So, I am confused about what to do now. Can someone please help me understand what is going wrong and how I can fix it. Thanks a lot, because I am stuck.
__________________
[COLOR="Lime"]-------Bass Vids!!!
[url]http://www.youtube.com/watch?v=wjaJSeq-K3g[/url]
[url]http://www.youtube.com/watch?v=entMYOguye[/url]
[url]http://www.youtube.com/watch?v=HP2oaTLN81E[/url][/COLOR]
southsidehustler is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-18-2009, 05:59 PM   #2
You Smell That?!?!

Nation Elite Contributing Member How-To CM SuperMeet Organizer Skitz Award 100K SESM 09 SESM 10 TXSM 10 

 
rtmsu_02's Avatar
 
Join Date: May 2009
Location: Iowa, La
Posts: 6,214
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Failed inspection. No reading from obd2. Help please

srsly, i never had them plug into my truck to do an inspection in Louisiana....go to a diff place?
__________________

2004 Silver birch Canyon Z71 SLE 4x4 130,000 miles and counting
BBB crew...all day, every day.
rtmsu_02 is offline   Reply With Quote
Old 10-18-2009, 06:24 PM   #3
Nation Elite

Calendar Spread SESM 09 SESM 10 

 
csharp's Avatar
 
Join Date: Aug 2009
Location: welsh louisiana
Posts: 2,183
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Failed inspection. No reading from obd2. Help please

yea go somewere else that dont go on round here
__________________
still the best in styling LA 355

csharp is offline   Reply With Quote
Old 10-18-2009, 06:35 PM   #4
New To The Nation
 
Join Date: Oct 2007
Location: Albany, Louisiana
Posts: 69
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Failed inspection. No reading from obd2. Help please

yeah, I can go somewhere else but I still wouldn't mind knowing what is messed up. ya know.
__________________
[COLOR="Lime"]-------Bass Vids!!!
[url]http://www.youtube.com/watch?v=wjaJSeq-K3g[/url]
[url]http://www.youtube.com/watch?v=entMYOguye[/url]
[url]http://www.youtube.com/watch?v=HP2oaTLN81E[/url][/COLOR]

Last edited by southsidehustler; 10-18-2009 at 06:50 PM.
southsidehustler is offline   Reply With Quote
Old 10-18-2009, 06:45 PM   #5
You Smell That?!?!

Nation Elite Contributing Member How-To CM SuperMeet Organizer Skitz Award 100K SESM 09 SESM 10 TXSM 10 

 
rtmsu_02's Avatar
 
Join Date: May 2009
Location: Iowa, La
Posts: 6,214
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Failed inspection. No reading from obd2. Help please

yea, go to auto zone and see if their reader works..... maybe a bad obdII scanner ?
__________________

2004 Silver birch Canyon Z71 SLE 4x4 130,000 miles and counting
BBB crew...all day, every day.
rtmsu_02 is offline   Reply With Quote
Old 10-18-2009, 07:04 PM   #6
Nation Affiliate
 
zuschke's Avatar
 
Join Date: Jan 2009
Location: Charlotte
Posts: 165
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Failed inspection. No reading from obd2. Help please

this is going to sound weird but..... here goes

I had the same problem on my 07 rado, the guy proceeded to open the fuse box and remove the fuse for the Radio. Then he hooked up to the OBD2 and everything worked perfectly. Then he put the fuse back in and i was on my way. Only issue was my radio stations being wiped out. The tech response was that he had to do that with a lot of colorados.

same thing happend when i was getting my tune. removed the radio fuse and.... it worked

i dont know if this will work for you, or why it works, or what the hell the radio has to do with anything related... never the less, good luck
zuschke is offline   Reply With Quote
Old 10-18-2009, 08:39 PM   #7
New To The Nation
 
Join Date: Oct 2007
Location: Albany, Louisiana
Posts: 69
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Failed inspection. No reading from obd2. Help please

Thanks! I will give it a try tomorrow.
__________________
[COLOR="Lime"]-------Bass Vids!!!
[url]http://www.youtube.com/watch?v=wjaJSeq-K3g[/url]
[url]http://www.youtube.com/watch?v=entMYOguye[/url]
[url]http://www.youtube.com/watch?v=HP2oaTLN81E[/url][/COLOR]
southsidehustler is offline   Reply With Quote
Old 10-18-2009, 09:08 PM   #8
You Smell That?!?!

Nation Elite Contributing Member How-To CM SuperMeet Organizer Skitz Award 100K SESM 09 SESM 10 TXSM 10 

 
rtmsu_02's Avatar
 
Join Date: May 2009
Location: Iowa, La
Posts: 6,214
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Failed inspection. No reading from obd2. Help please

i have heard of that...the radio interferes with communications....when u get a tune, you should be asked to remove your radio fuse.....or at least every person i ever heard of has been asked.
__________________

2004 Silver birch Canyon Z71 SLE 4x4 130,000 miles and counting
BBB crew...all day, every day.
rtmsu_02 is offline   Reply With Quote
Old 10-18-2009, 10:08 PM   #9
SuspensionMAXX Site Sponsor

Military Service OG Lifetime Contributing Member How-To CM Nation Vendor 355 Celebrity MTS 

 
ssgjurista's Avatar
 
Join Date: Mar 2009
Location: Fort Carson, CO
Posts: 3,514
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via Yahoo to ssgjurista
Re: Failed inspection. No reading from obd2. Help please

Quote:
Originally Posted by southsidehustler View Post
So, I went to get an inspection sticker and their machine could not get a reading from my obd2. They told me that this is usually from a blown cigarette lighter fuse. So I checked both fuses, and tested both cigarette lighters and everything is good. I haven't had any issues with my truck. And I just took a test light to every fuse and everything is receiving power. I have been looking around for a loose wire or bent pin but I don't see any problems. There are 4 wires hooked into the plug. They are: orange, black/white striped, black, purple. I got the dmm and the orange is the 12v (it was reading at the plug), and it appeared that all the other wires were ground. I left the positive lead from the dmm touching the Orange and touched the negative lead on each of the remaining 3 wires and got a 12+ reading.
So, I am confused about what to do now. Can someone please help me understand what is going wrong and how I can fix it. Thanks a lot, because I am stuck.
You have power but the scanner 'talks' to the PCM through the purple wire. Plug another scanner into the OBD-II port and see if it works. The schematics are a sticky in this section
'Special Schematics 2004-2008 Part 1'. Once it unzips, select 'Data Link Connector'.
__________________
2005 Z71 LS Crew Cab 4X4 L52, 4L60E, GT4, Silver Birch Metallic, Amsoil Synthetics, SSK Black Chrome Shifter
MAXX Shackles: Click Here!
MAXX Cam JR Lift Kit for 4X4 & 2WD Z71
: Click Here!
MAXX Stak Lift Kit for 2WD: Click Here!
PerforMAXX Body Lift: Click Here!
ssgjurista is offline   Reply With Quote
Old 10-19-2009, 08:35 AM   #10
Nation Elite

355 O.G. Nation Elite Contributing Member 

 
ZNA03's Avatar
 
Join Date: Apr 2007
Location: Wellington, Florida
Posts: 3,444
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via AIM to ZNA03
Re: Failed inspection. No reading from obd2. Help please

Quote:
Originally Posted by rtmsu_02 View Post
i have heard of that...the radio interferes with communications....when u get a tune, you should be asked to remove your radio fuse.....or at least every person i ever heard of has been asked.
You only need to remove the fuse if you have issues. If no issues you just make sure the radio is off then fire away.
ZNA03 is offline   Reply With Quote
Old 10-19-2009, 02:14 PM   #11
2x Canyon Survivor

355 O.G. Chapter Founder Nation Elite OG Lifetime Contributing Member How-To CM Nation Vendor SuperMeet Organizer Nation Advocate 355Loyalty 100K NESM 08 NESM 09 NESM 11 SESM 11 

 
Canyon08Z71's Avatar
 
Join Date: Apr 2007
Location: Massachusetts
Posts: 3,862
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Re: Failed inspection. No reading from obd2. Help please

Quote:
Originally Posted by ZNA03 View Post
You only need to remove the fuse if you have issues. If no issues you just make sure the radio is off then fire away.
Certain head unit adapters will cause the interference.

Service Bulletin: LAN/CAN comm. interference caused by after market radio harness

The above link will show you one of them to NEVER install on your Colorado or Canyon!

My guesstimation is along the same lines as the others stated... Something is jamming up the Readiness Tests in the PCM (if you are certain you have 12V to the ODBII plug). You need to find what is causing the interference, have a scan tool available to see the readiness test status.
__________________
Gerry


Advanced Vehicle Technologies
Canyon08Z71 is offline   Reply With Quote
Old 10-19-2009, 06:22 PM   #12
Members Technical !@#!@#!@#!@#!@#

Nation Elite Contributing Member How-To CM Calendar Spread 355 Celebrity MTS 100K SESM 09 SESM 10 TXSM 11 

 
Slo86GT's Avatar
 
Join Date: Dec 2008
Location: Tomball, TX
Posts: 6,799
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage
Re: Failed inspection. No reading from obd2. Help please

Nice link, never heard that before. I've got the Metra unit from Crutchfield, so I guess I'm in the clear.
__________________

- Jody -
Quote:
Knowledge and finger vomit are easily confused over the internet.
Slo86GT is offline   Reply With Quote
Old 10-20-2009, 12:26 AM   #13
Nation Master

Military Service Nation Elite Contributing Member How-To CM Nation Advocate Calendar Spread 355 Celebrity Skitz Award NESM 09 NESM 10 

 
greg larkins's Avatar
 
Join Date: Sep 2007
Location: DC Metropolitan Area
Posts: 7,667
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Failed inspection. No reading from obd2. Help please

wow, i've never heard about that before either. good thing too, because i just got my emissions testing done today. PASS. i guess that means i don't have the crappy interface module?
__________________

black letters > green letters
greg larkins is offline   Reply With Quote
Old 10-20-2009, 09:13 PM   #14
New To The Nation
 
Join Date: Oct 2007
Location: Albany, Louisiana
Posts: 69
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Failed inspection. No reading from obd2. Help please

I wanted to give you guys an update. I went back today, pulled the radio fuse and it worked. Thanks for the help everyone.
__________________
[COLOR="Lime"]-------Bass Vids!!!
[url]http://www.youtube.com/watch?v=wjaJSeq-K3g[/url]
[url]http://www.youtube.com/watch?v=entMYOguye[/url]
[url]http://www.youtube.com/watch?v=HP2oaTLN81E[/url][/COLOR]
southsidehustler is offline   Reply With Quote
Old 10-21-2009, 08:22 AM   #15
Nation Elite

355 O.G. Nation Elite Contributing Member 

 
ZNA03's Avatar
 
Join Date: Apr 2007
Location: Wellington, Florida
Posts: 3,444
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via AIM to ZNA03
Re: Failed inspection. No reading from obd2. Help please

Quote:
Originally Posted by southsidehustler View Post
I wanted to give you guys an update. I went back today, pulled the radio fuse and it worked. Thanks for the help everyone.
Sweet!
ZNA03 is offline   Reply With Quote
Old 10-21-2009, 09:02 AM   #16
"ALL JACKED UP"

Military Service TOTM Winner Contributing Member Calendar Spread 355 Celebrity Skitz Award 355Loyalty 100K NESM 09 

 
Kraco5's Avatar
 
Join Date: Dec 2007
Location: Brunswick, Ohio
Posts: 2,334
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Re: Failed inspection. No reading from obd2. Help please

I had the same prob. they told me either go get it fixed or they could test it the old fashion way. I told them check it the old fashion way cause their was nothing wrong with the truck.......sure enough I passed.
__________________
Kraco5 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


LinkBacks (?)
LinkBack to this Thread: http://www.355nation.net/forum/electrical-lighting-security/22915-failed-inspection-no-reading-obd2-help-please.html
Posted By For Type Date
OBD2 Port - Southern California Colorado & Canyon Chapter -- SoCal355.com This thread Refback 01-03-2010 04:16 PM


All times are GMT -4. The time now is 12:01 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
User Alert System provided by Advanced User Tagging v3.0.6 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
All content copyright 355Nation.net

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.3.0