Cruise Control Not Working - Chevrolet Colorado & GMC Canyon Forum
Chevrolet Colorado & GMC Canyon Forum
 
Go Back   Chevrolet Colorado & GMC Canyon Forum > Tech Area - First Generation (2004-2012) > Engines/Performance/Tech Questions > I4/I5 Engine & Drivetrain

355Nation.net is the premier Chevrolet Colorado Forum on the internet. Registered Users do not see the above ads.
User Tag List

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 09-29-2010, 02:17 PM   #1
Jim
New To The Nation
 
Jim's Avatar
 
Join Date: Oct 2009
Location: Northern Kentucky
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Cruise Control Not Working

My 2009's cruise doesn't work and the 10A fuse is good. I thought it could be in the PCM and disconnected the battery to "reboot" it, but no change. Any ideas? Anyone have this problem before?

It is under warranty but before I bring it to the dealer I better undo the low/high beam mod, fog light on high mod, RAP power mod, etc. so they won't tell me my warranty is void.

Thanks, Jim
__________________

2009 Colorado Z71 4x4 Extended Cab 3.7L

Truxedo Truxport Soft Tonneau Cover, Dynolock Electric Tailgate Lock,
OEM Nerf Bars & Mud Flaps, Lund Bug Deflector, Window Vent Shades,
Dual High/Low Beam mod, Fog Light on High Beam mod, 4500k HID Low Beams & Fog Lights
Jim is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-29-2010, 02:18 PM   #2
Captain Obvious

Nation Elite Contributing Member 100K SESM 09 SESM 10 MESM 10 

 
trueblue's Avatar
 
Join Date: Aug 2008
Location: PCB, FL
Posts: 3,657
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage
Re: Cruise Control Not Working

have you check your brake lights? it won't work if one burns out.
__________________


Quote:
Originally Posted by unicknn View Post
your weiner is pretty small man
Quote:
Originally Posted by rcogan86 View Post
yea, it happens..
trueblue is offline   Reply With Quote
Old 09-29-2010, 02:21 PM   #3
Nation Elite

355 O.G. Contributing Member How-To CM Nation Advocate Public Service NESM 09 

 
rangerbob's Avatar
 
Join Date: Apr 2007
Location: Germantown, MD
Posts: 2,643
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via AIM to rangerbob
Re: Cruise Control Not Working

Got search? Brake light bulb out is the most likely cause.
__________________
05 Canyon EC SLE - I5M Z71 4x4 GT4 25 Aug - 126k miles
LED + HAW Strobes | Fold-A-Cover | Line-X OTR | Goodmark Cowl Hood | GP Seats
1.5TB/2.5AAL/1BL/.5Diff Drop | RS5300/MA764 Shocks | Bubaloo Skidz | BFG 33-12.5-15 AT/KO
1st Cat Delete | MBRP 409 Turndown | FRAM Boost+RamAir | 3 x Lightforce Blitz | eFan | Tune by Gerry <- Awesome!!!
rangerbob is offline   Reply With Quote
Old 09-29-2010, 02:21 PM   #4
Jim
New To The Nation
 
Jim's Avatar
 
Join Date: Oct 2009
Location: Northern Kentucky
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Cruise Control Not Working

Quote:
Originally Posted by trueblue View Post
have you check your brake lights? it won't work if one burns out.
No, but I will - have you seen that before? I thought the CC only uses the brake light switch at the pedal, not actually sensing the lights.
__________________

2009 Colorado Z71 4x4 Extended Cab 3.7L

Truxedo Truxport Soft Tonneau Cover, Dynolock Electric Tailgate Lock,
OEM Nerf Bars & Mud Flaps, Lund Bug Deflector, Window Vent Shades,
Dual High/Low Beam mod, Fog Light on High Beam mod, 4500k HID Low Beams & Fog Lights
Jim is offline   Reply With Quote
Old 09-29-2010, 02:23 PM   #5
Jim
New To The Nation
 
Jim's Avatar
 
Join Date: Oct 2009
Location: Northern Kentucky
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Cruise Control Not Working

Quote:
Originally Posted by rangerbob View Post
Got search? Brake light bulb out is the most likely cause.
I tried searching first - nothing came up.

Thanks to both for the resonses.
__________________

2009 Colorado Z71 4x4 Extended Cab 3.7L

Truxedo Truxport Soft Tonneau Cover, Dynolock Electric Tailgate Lock,
OEM Nerf Bars & Mud Flaps, Lund Bug Deflector, Window Vent Shades,
Dual High/Low Beam mod, Fog Light on High Beam mod, 4500k HID Low Beams & Fog Lights
Jim is offline   Reply With Quote
Old 09-29-2010, 02:31 PM   #6
Nation Affiliate

Purple Heart Military Service 

 
awp101's Avatar
 
Join Date: May 2010
Location: The nurturing biosphere of the Mothership aka TX
Posts: 449
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Cruise Control Not Working

I bet you have no brake lights either. When the switch goes out, you lose the brake lights AND the cruise. Happened on my old 05 CC and found out there was a recall for that.
__________________
Make yourself an honest man, and then you may be sure that there is one less scoundrel in the world. - Thomas Carlyle

Sometimes when I'm bored, I like to text "I hid the body, now what?" to a random phone number...

Nothing so needs reforming as other people's habits. - Mark Twain

Spell Check: It's your friend

When I dance with wolves, it's usually the Tango
awp101 is offline   Reply With Quote
Old 09-29-2010, 02:35 PM   #7
Members Technical Staff

TOTM Winner Nation Elite Calendar Spread MTS Skitz Award SESM 09 SESM 10 SESM 11 

 
LowRadoNLa's Avatar
 
Join Date: Jan 2009
Location: Baton Rouge, La
Posts: 7,538
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Cruise Control Not Working

there is a 2nd recall on brake light switches....also did you install an ebay LED third brake light? that has caused some issues as well
__________________
UNDERGROUND....IT'S A LIFESTYLE

JOIN THE REVOLUTION
LowRadoNLa is offline   Reply With Quote
Old 09-29-2010, 02:43 PM   #8
Jim
New To The Nation
 
Jim's Avatar
 
Join Date: Oct 2009
Location: Northern Kentucky
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Cruise Control Not Working

Quote:
Originally Posted by awp101 View Post
I bet you have no brake lights either. When the switch goes out, you lose the brake lights AND the cruise. Happened on my old 05 CC and found out there was a recall for that.
I just went outside to check & you are right - no brake lights. You would have thought that they would have corrected the problem by now in my 2009 but I guess not.

Thanks guys - that saved me a lot of trouble-shooting time!
__________________

2009 Colorado Z71 4x4 Extended Cab 3.7L

Truxedo Truxport Soft Tonneau Cover, Dynolock Electric Tailgate Lock,
OEM Nerf Bars & Mud Flaps, Lund Bug Deflector, Window Vent Shades,
Dual High/Low Beam mod, Fog Light on High Beam mod, 4500k HID Low Beams & Fog Lights
Jim is offline   Reply With Quote
Old 09-29-2010, 02:47 PM   #9
Nation Affiliate

Purple Heart Military Service 

 
awp101's Avatar
 
Join Date: May 2010
Location: The nurturing biosphere of the Mothership aka TX
Posts: 449
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Cruise Control Not Working

Makes you break out in a cold sweat when you think about that last trip around town, doesn't it?

Get a hold of a/the dealer and get it corrected for free (IF the recall is still underway).
__________________
Make yourself an honest man, and then you may be sure that there is one less scoundrel in the world. - Thomas Carlyle

Sometimes when I'm bored, I like to text "I hid the body, now what?" to a random phone number...

Nothing so needs reforming as other people's habits. - Mark Twain

Spell Check: It's your friend

When I dance with wolves, it's usually the Tango
awp101 is offline   Reply With Quote
Old 09-29-2010, 04:59 PM   #10
Jim
New To The Nation
 
Jim's Avatar
 
Join Date: Oct 2009
Location: Northern Kentucky
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Cruise Control Not Working

Right - not knowing they are out can be dangerous.

I pulled the switch, p/n 25796381 (I think it will be superceded by p/n 20913529). It is a NC switch (when brake pedal is depressed) but this switch was closed regardless. I took it apart & re-assembled it & now it works, but who knows for how long.

I ordered 2 switches from RockAuto for $6.50 each + $3.16 S&H.
__________________

2009 Colorado Z71 4x4 Extended Cab 3.7L

Truxedo Truxport Soft Tonneau Cover, Dynolock Electric Tailgate Lock,
OEM Nerf Bars & Mud Flaps, Lund Bug Deflector, Window Vent Shades,
Dual High/Low Beam mod, Fog Light on High Beam mod, 4500k HID Low Beams & Fog Lights

Last edited by Jim; 10-01-2010 at 12:06 PM. Reason: Not necessarily a recall issue.
Jim is offline   Reply With Quote
Old 10-01-2010, 12:20 PM   #11
Jim
New To The Nation
 
Jim's Avatar
 
Join Date: Oct 2009
Location: Northern Kentucky
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Cruise Control Not Working

I re-installed the now-working brake light switch and still no brake lights. I found the 20A fuse was blown in addition to the switch contacts fused closed. I think I know the reason: A couple of weeks ago I hooked up my boat trailer lights but one of the sealed tail light assemblies was half full of water & probably shorted out the lights.

So now the brake lights work fine, but cruise control is still not working. The 2nd switch at the brake pedal is the cruise / TCC release (opens when the pedal is depressed) and it is working fine. Any ideas? I'm afraid the PCM was damaged and will have the dealer look at it once I replace the relays for the fog & high/low mods listed in my sig above & return to stock so the dealer doesn't try to say my warranty is void. Those mods are unrelated to this problem.
Jim is offline   Reply With Quote
Old 10-04-2010, 07:56 AM   #12
Jim
New To The Nation
 
Jim's Avatar
 
Join Date: Oct 2009
Location: Northern Kentucky
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Cruise Control Not Working

Two days after fixing the brake lights the cruise started working again. The PCM must require a certian number of cycles to reset itself.
Jim is offline   Reply With Quote
Old 10-04-2010, 08:34 AM   #13
Texas Yoda!!!!

Nation Elite Contributing Member SuperMeet Organizer Calendar Spread Skitz Award USASM2012 SESM 10 SESM 11 TXSM 10 TXSM 11 TXSM 14 

 
edvocho's Avatar
 
Join Date: Mar 2008
Location: Your mom's house
Posts: 35,436
Mentioned: 41 Post(s)
Tagged: 2 Thread(s)
Garage
Re: Cruise Control Not Working

Glad they are working now!
__________________
||.:R.I.P Skitz 06/20/1984-06/27/2011:.||
Facebook 355Nation's Facebook Group
edvocho is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Tags
brake light switch, cruise control

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 12:02 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
User Alert System provided by Advanced User Tagging v3.0.6 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
All content copyright 355Nation.net

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.3.0