p0017 CEL code - Chevrolet Colorado & GMC Canyon Forum
Chevrolet Colorado & GMC Canyon Forum
 
Go Back   Chevrolet Colorado & GMC Canyon Forum > Tech Area > Engines/Performance/Tech Questions > I4/I5 Engine & Drivetrain

355Nation.net is the premier Chevrolet Colorado Forum on the internet. Registered Users do not see the above ads.
User Tag List

Reply
 
LinkBack (3) Thread Tools Search this Thread Display Modes
Old 04-13-2011, 11:23 PM   3 links from elsewhere to this Post. Click to view. #1
Nation Affiliate
 
Martin_the_great's Avatar
 
Join Date: Jan 2011
Location: Saskatoon, Saskatchewan, Canada
Posts: 188
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
p0017 CEL code

Anyone have any ideas what it may be? I have changed the Camshaft sensor and the actuator valve right next to it... is it calling for a crank sensor? If so where on the engine is it located?

Martin_the_great is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-13-2011, 11:41 PM   #2
Nation Citizen

Contributing Member How-To CM Public Service 355Loyalty 

 
jrotundo's Avatar
 
Join Date: May 2010
Location: honesdale, pa
Posts: 1,894
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: p0017 CEL code

http://www.355nation.net/forum/engin...am-sensor.html

from the posts in that thread, it can only be either the cam sensor or cam actuator someone else will chime in im sure.
jrotundo is offline   Reply With Quote
Old 04-14-2011, 12:02 AM   #3
Nation Affiliate
 
Martin_the_great's Avatar
 
Join Date: Jan 2011
Location: Saskatoon, Saskatchewan, Canada
Posts: 188
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: p0017 CEL code

Ya well both are changed... so I am at a loss
Martin_the_great is offline   Reply With Quote
Old 04-14-2011, 12:09 AM   #4
Nation Citizen

Contributing Member How-To CM Public Service 355Loyalty 

 
jrotundo's Avatar
 
Join Date: May 2010
Location: honesdale, pa
Posts: 1,894
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: p0017 CEL code

reset the code and maybe leave the battery disconnected for 20 min...?
jrotundo is offline   Reply With Quote
Old 04-14-2011, 03:24 PM   #5
Nation Affiliate
 
Martin_the_great's Avatar
 
Join Date: Jan 2011
Location: Saskatoon, Saskatchewan, Canada
Posts: 188
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: p0017 CEL code

I have erased the code with the reader and have done the battery thing. Nothing.

Any chance its the crankshaft sensor?
Martin_the_great is offline   Reply With Quote
Old 04-17-2011, 01:12 PM   #6
New To The Nation
 
Join Date: Jan 2011
Location: vista ca.
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: p0017 CEL code

I'm haveing the same code issue. 2006 3.5 Is it possible the oil passeges at the end of the cam actuator is plugged?
bgchlln is offline   Reply With Quote
Old 04-17-2011, 01:26 PM   #7
Nation Master

Chapter Founder Nation Elite 100K USASM2012 MESM 10 MESM 11 

 
07ColoradoBLK's Avatar
 
Join Date: Apr 2008
Location: Saint Louis, Missouri
Posts: 4,301
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage
Re: p0017 CEL code

im having the same thing bro.. it'll come on every once in a while and then it'll turn itself off .and be off for months on end then randomly come back .

ive changed both sensors, and reset battery 8 times.. cleared code 5 with code reader. its a never ending battle

2007 2.9L
__________________

facebook
http://www.355nation.net/forum/stl355/
R.I.P Skitz 6/20/84-6/27/11
STL355
07ColoradoBLK is offline   Reply With Quote
Old 04-17-2011, 04:40 PM   #8
Nation Affiliate
 
Martin_the_great's Avatar
 
Join Date: Jan 2011
Location: Saskatoon, Saskatchewan, Canada
Posts: 188
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: p0017 CEL code

From what we have been reading, its just the actuator valve that everyone has been changing. But if we have done that and its still coming back... what else could it be? Could it be the camshaft actuator itself? One of the mechanics at the dealership said to maybe run some engine flush or some seafoam engine treatment through.
Martin_the_great is offline   Reply With Quote
Old 04-18-2011, 02:43 PM   #9
Nation Elite
 
Join Date: May 2008
Location: Anniston, Alabama
Posts: 2,059
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Re: p0017 CEL code

i had the same problem with it coming and going even after i replaced the exhaust camshaft position thingie. the first one was from rock auto and it was a POS after that i bought one from the dealership now the truck runs perfect.
__________________
Quote:
Originally Posted by kerad11 View Post
Ive had a hot one in my mouth and i loved it.

Every inch of it.
pcream is offline   Reply With Quote
Old 04-18-2011, 05:11 PM   #10
Nation Affiliate
 
Martin_the_great's Avatar
 
Join Date: Jan 2011
Location: Saskatoon, Saskatchewan, Canada
Posts: 188
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: p0017 CEL code

I bought the sensors from a dealership. The Actuator valve solenoid was from a wrecker... maybe that one is messed up too?
Martin_the_great is offline   Reply With Quote
Old 04-18-2011, 05:28 PM   #11
Nation Elite
 
Join Date: May 2008
Location: Anniston, Alabama
Posts: 2,059
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Re: p0017 CEL code

when i bought mine the guy at the parts desk said they keep 10 instock b/c they fuck up so much. it wouldnt hurt to pull it out and look at the screens since its just one bolt and a plug to remove it.
__________________
Quote:
Originally Posted by kerad11 View Post
Ive had a hot one in my mouth and i loved it.

Every inch of it.
pcream is offline   Reply With Quote
Old 04-21-2011, 01:05 PM   #12
Nation Affiliate
 
Martin_the_great's Avatar
 
Join Date: Jan 2011
Location: Saskatoon, Saskatchewan, Canada
Posts: 188
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: p0017 CEL code

Do I need a tech2 tool to relearn on the sensors?
Martin_the_great is offline   Reply With Quote
Old 04-27-2011, 03:19 PM   #13
Nation Affiliate

355 O.G. 

 
longbow986's Avatar
 
Join Date: Apr 2007
Location: Port Arthur
Posts: 282
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: p0017 CEL code

That my friends is the Camshaft actuator solenoid valve, which is on the passenger side of the engine, its right underneath the engine harness wire and just behind the oil filler cap! remove the screw and metal holder and check to see if its missing any of the screens, if so, replace it! it should be like 70 bucks or something, someone will chime in with a price hopefully.

---

ALSO WHILE WE'RE ON THIS SUBJECT.
Will the failure of this device cause the engine to run without VVT? and instead operate as a normal non-VVT engine? if anyone knows what the heck i mean by that.
__________________
http://i48.photobucket.com/albums/f212/LongBow986/MS14Gelgoogsig.jpg
It's idiot season
Let the hunting begin
longbow986 is offline   Reply With Quote
Old 04-27-2011, 09:45 PM   #14
SuspensionMAXX Site Sponsor

Military Service OG Lifetime Contributing Member How-To CM Nation Vendor 355 Celebrity MTS 

 
ssgjurista's Avatar
 
Join Date: Mar 2009
Location: Fort Carson, CO
Posts: 3,514
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via Yahoo to ssgjurista
Re: p0017 CEL code

Quote:
Originally Posted by longbow986 View Post
That my friends is the Camshaft actuator solenoid valve, which is on the passenger side of the engine, its right underneath the engine harness wire and just behind the oil filler cap! remove the screw and metal holder and check to see if its missing any of the screens, if so, replace it! it should be like 70 bucks or something, someone will chime in with a price hopefully.

---

ALSO WHILE WE'RE ON THIS SUBJECT.
Will the failure of this device cause the engine to run without VVT? and instead operate as a normal non-VVT engine? if anyone knows what the heck i mean by that.
Yes the engine will run in a non VVT mode, but you will usually (not always) get a trouble code if it fails.
__________________
2005 Z71 LS Crew Cab 4X4 L52, 4L60E, GT4, Silver Birch Metallic, Amsoil Synthetics, SSK Black Chrome Shifter
MAXX Shackles: Click Here!
MAXX Cam JR Lift Kit for 4X4 & 2WD Z71
: Click Here!
MAXX Stak Lift Kit for 2WD: Click Here!
PerforMAXX Body Lift: Click Here!
ssgjurista is offline   Reply With Quote
Old 04-29-2011, 01:34 AM   #15
Nation Affiliate
 
Martin_the_great's Avatar
 
Join Date: Jan 2011
Location: Saskatoon, Saskatchewan, Canada
Posts: 188
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: p0017 CEL code

All screens are there.
Martin_the_great is offline   Reply With Quote
Old 04-29-2011, 02:03 AM   #16
Member's Technical crew

Nation Elite Contributing Member How-To CM MTS Skitz Award 100K 

 
banditz's Avatar
 
Join Date: Jan 2009
Location: concord, NC
Posts: 12,060
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: p0017 CEL code

I just sold that sensor off my old 3.5 for like next to nothing..if I still had it I would have sent it to ya man, sorry.


Now as for your issue.

When you say crank sensor I am guessing you mean the crank shaft sensor. i do still have that one. It's located down on the driver's side at the bottome. Near teh back of the block. It will be the ONLY one near the back of the block on teh driver's side. You remove one bolt and a decently long sensor will come right out. make sure before you replace it that the wire's are not cut or something like that, otherwise replaceing it would be pointless.

let me know if you want it, i can ship asap now and will be dirt cheap.
__________________
When firearms are outlawed only outlaws will have them! And I personally refuse to be a victim, be it from a outlaw, or from a corrupt government!!!!!

Christian= A sinner who keeps on trying!

CAROLINA CHAPTER Chapter Leader. Live in the carolina's or close, join up!
banditz is offline   Reply With Quote
Old 04-29-2011, 02:08 AM   #17
macNcheese

TOTM Winner Nation Elite OG Lifetime Contributing Member How-To CM Calendar Spread Skitz Award 100K USASM2012 WCSM 10 WCSM 2014 

 
xkmacx86's Avatar
 
Join Date: Mar 2008
Location: Sparks, Nevada
Posts: 9,307
Mentioned: 2 Post(s)
Tagged: 1 Thread(s)
Re: p0017 CEL code

sometimes if the screens are clogged, even thought all are present, the actuator can fail.

this seems to be a common issue recently. i just wish i had these threads a while back when i was having problems.
__________________
AUG 2011 ~~~ TWO TIME 355NATION TOTM WINNER ~~~ DEC 2012

Want a sig this big? Want to access exclusive content? Become a contributing member today!
Top Free Cheap Performance Mods ~ Essential Maintenance Compilation
04-08 MOTOR SWAP PROVEN!!!
Quote:
Originally Posted by M_O_Z View Post
I hope to start soon as I get another dd
WE'RE WAITING...........................
xkmacx86 is offline   Reply With Quote
Old 04-29-2011, 05:15 PM   #18
Nation Affiliate

355 O.G. 

 
longbow986's Avatar
 
Join Date: Apr 2007
Location: Port Arthur
Posts: 282
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: p0017 CEL code

Thanks for keying in on that SSGJurista i knew it wouldnt affect TOO much, but i do know that without that particular system functioning, you lose a hair of power and gas mileage.

Good to get it replaced. damned expensive tho, even tho its a QUICK AS HELL fix, if i get another one, i might make a how to on replacement
__________________
http://i48.photobucket.com/albums/f212/LongBow986/MS14Gelgoogsig.jpg
It's idiot season
Let the hunting begin
longbow986 is offline   Reply With Quote
Old 04-30-2011, 12:09 PM   #19
Nation Affiliate
 
Martin_the_great's Avatar
 
Join Date: Jan 2011
Location: Saskatoon, Saskatchewan, Canada
Posts: 188
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: p0017 CEL code

I actually took the sensor apart and cleaned it. There is an allan head screw at the end of the shaft. It unscrews a cap, then a ball and spring come out too. I cleaned it in the varsol tank at work and still nothing May try a crank sensor next.
Martin_the_great is offline   Reply With Quote
Old 05-03-2011, 06:51 PM   #20
New To The Nation
 
Join Date: Feb 2011
Location: Phoenix az
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: p0017 CEL code

My truck is running good but it just is running warm and has a check engine light for P0017 as well. It does not stumble or misfire. I replaced the solenoid assy with a new dealer unit and the truck stumbled and would not run....bad unit from dealer? maybe. got another one, same thing.... put the original one in runs smooth but check engine light came right on. i OHMED checked the old solenoid and it was good.
So I replaced the camshaft position sensor with a new one no change.....
crankshaft position position sensor....no change.
I then removed the valve cover(pain in the butt) and checked the timing....as per mitchell on demand, at top dead center the camshaft position actuator was not lined up. After releasing oil pressure we tried to move the actuator and it seemed to be locked up.....ordered a new item hopefully it will fix this problem. It will not advance and seems to be stuck wide open. I will tell you if it works.
boneheadracer is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


LinkBacks (?)
LinkBack to this Thread: http://www.355nation.net/forum/i4-i5-engine-drivetrain/43702-p0017-cel-code.html
Posted By For Type Date
What is CODE P0017? This thread Refback 02-14-2014 01:40 AM
08 Colorado P0017 at Askives This thread Refback 12-21-2013 04:46 AM
p0017 CEL code - Chevrolet Colorado & GMC Canyon Forum This thread Refback 11-18-2013 08:54 AM


All times are GMT -4. The time now is 07:40 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
User Alert System provided by Advanced User Tagging v3.0.6 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
All content copyright 355Nation.net

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.3.0