Chevrolet Colorado & GMC Canyon Forum banner
overheating
1-7 of 7 Results
  1. I4/I5 Engine & Drivetrain
    Hello, all. This is my first post on these forums as it seems to be a pretty thorough resource for Colorado owners. I own a 2008 Colorado, 170k miles, I5 3.7L. She's been pretty good to me until this year when it started overheating. It started back in the summer so I replaced the thermostat...
  2. Engines/Performance/Tech Questions
    Hi, I have a 2004 Chevy Colorado 3.5L... I know the original thermostat releases at 180 degrees. The new ones release at 190 something.... does anyone know of a thermostat that releases at 180 besides the Stant Thermostat?
  3. Engines/Performance/Tech Questions
    Hi, I have a 2004 Colorado LS 3.5L with 80,000 miles. Its been overheating lately. I changed out the thermostat and it didn't help. The water pump seems fine and heat comes out in the cabin if the heater is turned on. The bearings are also ok and no leaks anywhere. I also burped the...
  4. I4/I5 Engine & Drivetrain
    I have a 2004 GMC Canyon SLE 5cyl with about 118k miles on it. This week the air conditioner stopped working out of the blue. Then the next small trip I made, it started working fine again. Then I got the “ac off/eng hot” message. It is running hot, too. I could only drive maybe 2 miles with the...
  5. Engine Swaps
    Im running into an issue where my temp rises past 210° while driving. If i let it idle the temperature goes back down to 200° and stays there while idling. I have an lm7 engine. I have the stock 2.9l radiator. I have gates rad hoses. I have burped the system the best i could. I do have the rear...
  6. Engine Swaps
    I need help on resolving my running temp. When im driving my temp climbs to 220°. I have a lm7 swap with a gates 33910 thermostat that is 180°. I have this ls1 fan. When i stop and let it idle the temperature goes down to 200°. What should I look for or what do i try to fix this?
  7. Engines/Performance/Tech Questions
    For awhile my canyon was running hot. At the 3/4 mark. I've changed the fan clutch, thermostat, water pump witch was leaking, and I also changed the temp sensor. It still runs a few clicks above the 1/2 mark. Sometimes closer to the 3/4 mark. Is this normal or should I be worried about a head...
1-7 of 7 Results
Top