Chevrolet Colorado & GMC Canyon Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I have a 04 Z71 Colorado 5 cyl, and have a fluctuation of the RPM at about 60 MPH, even with the cruise on.I have replaced the coil packs,plugs,cleaned the Maff sensor with the Maff sensor cleaner, checked /cleaned the air filter, checked for vacuum leaks( Only 2 places?) I have ordered a new Maff sensor and a Mapp sensor,but they haven't arrived yet. What could be causing the problem? The truck really runs great after the coil pack change,but seems to have improved after the MAFF sensor cleaning. I have no codes showing. Thanks in advance for any help.
 

·
US Army 19yrs and ......
Joined
·
45,273 Posts
What is the fluctuation you speak up 50rpm or more?

Are you sure its just not the converter locking or unlocking?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
I attempted to clean the Throttle body,and did a fair job, but I may have not cleaned it as it should have been. I am going to purchase the fuel filter this weekend as well. The RPM is more than 500-800 RPM up and down. Some times it doesn't jump as much. What would cause the converter to do this? The engine seems to drop power. Is there a preferred way to clean the Throttle Body? Thanks again.
 

·
Registered
Joined
·
2,686 Posts
sounds like the trans going
 

·
Premium Member
Joined
·
441 Posts
Another piece of the puzzle might be the fuel pressure regulator on the fuel rail. Maybe starting to develop a leak?
 

·
Registered
Joined
·
242 Posts
with that big of a jump, are you sure it just isn't kicking in/out of overdrive? I assume you have an automatic.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #11
Sorry for not getting back sooner,I want to apologize for being so foolish! I had checked the trans fluid about one month before, and it was full. After the plugs, coil packs,Maff,mapp, etc, I checked the trans, 3 qts low! Damn! How stupid! I just didn't think about that. I don't see any major leaks,but as soon as it warms up here, I am going to change the fluid and filter in the trans. I did however, add a bottle of Lucas to the trans, and still don't see any leaks. probably a front seal. Anyhoo,the truck really runs great now, and all the above items that were replaced really made a big difference in the overall power etc.Again, I am sorry to waste your time on this problem, but thanks for your help! I am sure I will not escape this world alive--------
 

·
the guy that always on
Joined
·
3,236 Posts
Sorry for not getting back sooner,I want to apologize for being so foolish! I had checked the trans fluid about one month before, and it was full. After the plugs, coil packs,Maff,mapp, etc, I checked the trans, 3 qts low! Damn! How stupid! I just didn't think about that. I don't see any major leaks,but as soon as it warms up here, I am going to change the fluid and filter in the trans. I did however, add a bottle of Lucas to the trans, and still don't see any leaks. probably a front seal. Anyhoo,the truck really runs great now, and all the above items that were replaced really made a big difference in the overall power etc.Again, I am sorry to waste your time on this problem, but thanks for your help! I am sure I will not escape this world alive--------
Time is only wasted on a problem if it remains unsolved.

Glad you got it fixed
 
1 - 12 of 12 Posts
Top