Chevrolet Colorado & GMC Canyon Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter #1
I am at my wits end with emissions on my 09 Colorado with the 2.9l in it. I can not get the readiness monitors for the cats and the evap to go into ready. Unfortunately my factory tune and what has been changed died with my friend Dave who tuned it for me. I just bought HP Tuners and deleted everything I thought was tripping it, but Im not sure what Dave had messed with in the past. I need a untouched factory tune file to compare to and reset everything.

If anyone can help at all, I would be forever grateful.
 

·
Registered
Joined
·
2,725 Posts
how manny miles have u put on it after the tune

me 2.9 been there too i feel for ya

i got a stock tune first then i wound up fixing the problems and after 200 miles lights went off

oh and do the how to for the evap much better also how many miles are on the truck could be u have a bad o2
 

·
Registered
Joined
·
87 Posts
Discussion Starter #3
Thanks for the reply :)

Right now I don't have any CEL's at all. I have them all turned off. The truck only has 50,000 miles on it. I have all the evap, cats, and o2's still on the truck even though it is bagged. The fuel tank and gas cap aren't stock because it has a fuel cell but it is a factory fuel pump and sending unit. The Evap has been relocated but is still hooked up as it should be. I have about 175-200 miles on it since I tuned out everything, but like I said, Im not sure what Dave had messed with to begin with. I have never seen the stock tune.

I looked at the How To and I have basically already done all of that with it being relocated.
 

·
Administrator
Joined
·
8,939 Posts
Thanks for the reply :)

Right now I don't have any CEL's at all. I have them all turned off. The truck only has 50,000 miles on it. I have all the evap, cats, and o2's still on the truck even though it is bagged. The fuel tank and gas cap aren't stock because it has a fuel cell but it is a factory fuel pump and sending unit. The Evap has been relocated but is still hooked up as it should be. I have about 175-200 miles on it since I tuned out everything, but like I said, Im not sure what Dave had messed with to begin with. I have never seen the stock tune.

I looked at the How To and I have basically already done all of that with it being relocated.
I have something that you can reference from.
Email me your file to [email protected]
 

·
Registered
Joined
·
87 Posts
Discussion Starter #6
Thanks for the help guys. I might just have to find a used car lot and pull a stock file. lol

I just emailed you Supermodulation.
 
1 - 6 of 6 Posts
Top