Chevrolet Colorado & GMC Canyon Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello all. I am desperate for some answers. We recently picked up a low mileage (48k) 2006 Chevy Colorado for my wife. She does home visits in Northern Michigan down a lot of crappy roads, thus the 4x4.

We just got it a couple weeks ago. The first week, it took a little to get it into 4x4, but went into 4wd hi and the light stayed solid in 4 hi. We could get it in 4hi and 2hi, no problem.

Now this week, the light continues to blink when putting it into 4 hi or 4 lo. I did a lot of reading, tried a few things and decided to grab a spare actuator. I replaced it and determined the one I had was working the same as the new one. While having the actuator out of the tcase, I could only get it to move after turning the key off and then on again. It wasn't moving when switching to 4 hi. I want to be clear, the light blinks on 4 hi or 4 lo, but doesn't automatically switch back to 2 hi, it just stays on 4 hi and blinks.

Also, when I try to put the transfer case into neutral, that light just sits and blinks as well.

So, so far I've replaced the actuator, pulled off the bezel and made sure the 4x4 switch was plugged in tightly. I haven't really inspected any of the wiring yet.

Any suggestions or things I can check? Or should i just take it to a repair shop and have them check it out for me?

Thanks for any advice.
:)
 

·
Registered
Joined
·
1,104 Posts
some times the 4wd on these trucks can be a little erratic, my truck will once in a while blink and not want to go into 4Lo, what I do is apply reverse, then neutral, and try again, if it dosnt work, I do neutral, reverse, let it roll a little, then neutral, then drive let it roll a little, then neutral, hit the 4Lo button and it works. I sometimes wish we just had a manual lever, so much more reliable.

Dorgie has a Masters Degree in fixing the 4wd on these trucks, maybe he will read and chime in on your issue.
 

·
Registered
Joined
·
682 Posts
I've always treated the buttons like it had a manual shift.Stopped all movement with the vehicle before selecting.Exspecially selecting low.Shifting out of 4 whl. to 2whl. always rolled backwards.
Never had confidence in the shifting on the fly crap.Guess i didn't want to have problems....and haven't since 2004 with the first colly.
Transfer case is a gear box.Oil can thicken when cold.Metal parts meshing together with a cold oil can react differently.If oil in transfer case has fines or never been changed that too can alter proper operation.
 

·
Registered
Joined
·
1,238 Posts
Was the transfer case ever serviced?
 

·
Registered
Joined
·
5 Posts
I just had this problem and recently got it solved! It turns out to be the transfer case control switch. The oxygen looking sensor on the bottom part of the tcase. I think the are only available at the stealership.
 

·
Registered
Joined
·
1,104 Posts
I just had this problem and recently got it solved! It turns out to be the transfer case control switch. The oxygen looking sensor on the bottom part of the tcase. I think the are only available at the stealership.
mind posting a part number if you have it?
 

·
maniac mechanic
Joined
·
5,779 Posts
Under the driver seat there is a control module. Make sure it didn't get wet and make sure the connector doesn't have any corrosion.
 

·
Registered
Joined
·
71 Posts
I just had this problem and recently got it solved! It turns out to be the transfer case control switch. The oxygen looking sensor on the bottom part of the tcase. I think the are only available at the stealership.
YA I would like this info also
 

·
Registered
Joined
·
5 Posts
I think I'm having the same issue--I pulled mine off the other day and the light stopped blinking..until I started driving (grrrr...) When I tested it, it read as a normally closed switch and seemed to have very distinct on and off positions. In that link above (thanks for that!) there appears to be another one at the top--does that mean there are 2 that could go bad?

I only pulled off the lower one so maybe I'll have to crawl under there and see if i can see the other one that is referred

thanks for the info BTW!
 

·
Registered
Joined
·
5 Posts
The other one is a neutral position switch, that could be it. Not sure what the symptoms are if that is bad but I'm sure you can test it like the shift control switch. Btw in that link if you click the diagram it will label each part.
 

·
Registered
Joined
·
5 Posts
Well I just called my dealer in Burlington and they want 152$ for just the part. I'm shocked to say the least. If anyone knows a cheaper spot please let me know!
 

·
Registered
Joined
·
5 Posts
Update of sorts for me--I disconnected the switch and shorted the two pins on the cable side (closed connection) light still flashes, opened the pins (open connection) light still flashes--so unless there is a series type situation where numerous things have to be inline before the damn light shuts off, i'm stuck--i'm fairly certain my switch is ok so I'm wondering where the wire goes--(there is a white'ish wire and black)--although not 100% certain due to grime...

maybe a break somewhere...wiring diagram anyone :D
 

·
maniac mechanic
Joined
·
5,779 Posts
They go to a control module under the driver seat as I stated about in an earlier post. Mine had corroded and had to be replaced and I had the same symptoms you are stating.

I think it was $148 for the module at my dealer.
 
1 - 20 of 22 Posts
Top