Chevrolet Colorado & GMC Canyon Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Four wheel drive button light blinks when
4 wheel high is pushed transfer case
Actuator is engaging. The only way to
get the hub actuator to activate is turn
The ignition off and back on but light still blinks
 

·
Registered
Joined
·
435 Posts
Sounds like its probably your 4x4 actuator down on the front diff. Have somebody push they button on the dash as your under the truck with your hand on it and see if it vibrates. It probably won't. Mine did the same thing awhile back. I removed mine and cleaned the black gunk outta it with brake cleaner. Its worked every time since

While its out, after u clean it. plug it in and hit the button n see if it extends the arm out. Fyi I will lose a bit of gear oil but not much to matter.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
Willie I was under the truck looking around today I came across a wire that looked to be taped that was going to what I think is a position sensor. I pulled the electrical tape off and the wire was broken so I put crimp and seal connectors back on it and now it works fine. Thanks for the information!
 

·
Registered
Joined
·
435 Posts
Willie I was under the truck looking around today I came across a wire that looked to be taped that was going to what I think is a position sensor. I pulled the electrical tape off and the wire was broken so I put crimp and seal connectors back on it and now it works fine. Thanks for the information!
Who's Willie? J/k. Glad u got it figured out. Those damn front actuator seem to shit the bed often
 
1 - 8 of 8 Posts
Top