Chevrolet Colorado & GMC Canyon Forum banner

4x4 will not work

1975 Views 9 Replies 5 Participants Last post by  hando5239
I bought my truck about a year ago and my 4wd never worked I took it to gm and they charged me about 1700 to try and fix it they changed the buttons they serviced the axles and they changed my tccm module the one that's under the drivers seat but when I press on the 4x4 button they only flash then they go back to 2wd nothing clicks no noises nothing idk what it could be that my 4wd does not engage anyone help me please I really want to fix my 4wd
1 - 10 of 10 Posts
Did they check the transfer case at all? Maybe the harness is damaged to it or the one of the servos is bad. You could also find a np241 tcase and swap it in. Would of cost probably half of what the dealer cost. Also you might want to have someone move this to the i4/i5 section.
So they charged you and they didn't fix it?
Try putting the t case in neutral and then try an engagr 4lo and 4hi if u get success with either then it might be your transfer case that took some damage internally.
If it's flashing and then not doing anything then it'd either be the harness or motors on the tcase.
What harness? The acctuator I've tried to put it in neutral and press on 4 high or low and I get nothing no clicks it does nothing at all I'm not sure if they checked my Axel or transfer case
Maybe its a dumb idea..but just in case check for a bad fuse.
"look under your truck at the front transfer case and see if the little electronic plastic thing that engages 4wd is connected properly."

stole that from c fans for you
IMA have to check under and look at all the connection to my transfer case and the acctuator
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.