Chevrolet Colorado & GMC Canyon Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 2015 Colorado LT 4x4 with 60k miles.
Driving to work the other day, I hit a bump in the road and within a second, my dashboard lite up with ABS, TC, Stabilitrak and even Emergency Brake lights. Also affected is my built in compass. It's showing CAL which I know means calibrate. At certain times, the lights all go off and the compass begins to work...then out of nowhere, the lights all come back on. When the lights are on, I know the ABS wasn't engaging since I could make it slide on our snowy roads. I had stopped at a local Monroe Muffler to have them hook up the scan tool they use and they couldn't connect to the brake module computer to figure out what is wrong. I have an appointment at a local GM dealership, but was hoping to not have to go that route since I have never had a positive experience at one. Has anyone had or heard of an issue like this? I'm thinking it could be a ABS speed sensor but which one to replace being they seem to be on every wheel. Would only one of the sensor's be linked to the compass which would verify that that would be the sensor to replace? Could the sensor just be dirty and need cleaned and reinstalled? Could a ground be at fault since the lights come on and off (but mainly stay on)?
 

·
Premium Member
Joined
·
248 Posts
I hate it when you type a paragraph of text, only to have your thumb hit something and get a ad. for a iPhone!
Anyway JMiz, ”I had the same experience last week. My “ABS Control Light came on as well as ABS FAIL in the mileage window. Took it to a local shop close to the house and told him what I had. He found that NO CODES were thrown. Then he advised me that the ABS CONTROL MODULES were known to be a weak point in the system. He said GM did not make them any longer for my truck. (2006). I replied, “I’ll get one from a salvage yard.”
Then the other day, while backing out of the drive way, It corrected itself! I suspect that this is what is happening to you. I located a couple of them on EBay. Yours my still be in production by GM.
 

·
Registered
Joined
·
20 Posts
This has been discussed numerous times on the coloradofans.com site ( its the sister site to this one) Many of us, myself included, have had this happen a couple of times, and shutting the truck off and restarting it after a couple of minutes has resolved the issue. However, there is an actual TSB or customer service bulletin on it, where a couple of different harnesses are too close to a protruding bolt.

Let me see if I can find it. In the mean time, you might be better helped on the other site which deals mores on with the 2nd Gen Colorado/Canyons for issues such as this.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top