Chevrolet Colorado & GMC Canyon Forum banner

1 - 20 of 28 Posts

·
[MTS] Who is this guy?
Joined
·
3,779 Posts
Discussion Starter #1 (Edited)
Hey guys as the title says, my A/C only blows cold while moving. This just started happening a few days ago. Everything else still works normally with the AC; all 4 speeds, recirc, etc.

It was suggested condenser fan by someone but googling has also returned that it could be a low freon level. The truck is a 2004 and I am pretty sure the AC is all original (aside from resistor in the cabin) and has never been recharged.

misc info: I have an efan not clutch fan and the truck is a 5spd 5cyl.

I was surprised in my searching that I didn't find anyone else on here with the same issue.
 

·
Registered
Joined
·
45 Posts
I am having trouble with my AC, Sometime when I drive, the ac will blow cold or warm air. It does that all the time, even when i am parked.

I have took my truck to the shop so many time while it was under warranty and they have replaced almost everything on my truck, the only thing they didn't do is the compressor and they refused to replace it because they said it's not the issue.

I have called GM and they kept referring me to speak with the manager at the shop where i always take it to and they are terrible.

I don't know what the problem is on your part and on my end.

I hope yours are simple fix.
 

·
Registered
Joined
·
2,685 Posts
It could be low on freon, could be that your efan isn't moving enough air. What efan do you have? Is it the supermod one? Or just one you got at an autoparts store? When was the efan installed?
 

·
[MTS] Who is this guy?
Joined
·
3,779 Posts
Discussion Starter #4
I am having trouble with my AC, Sometime when I drive, the ac will blow cold or warm air. It does that all the time, even when i am parked.

I have took my truck to the shop so many time while it was under warranty and they have replaced almost everything on my truck, the only thing they didn't do is the compressor and they refused to replace it because they said it's not the issue.

I have called GM and they kept referring me to speak with the manager at the shop where i always take it to and they are terrible.

I don't know what the problem is on your part and on my end.

I hope yours are simple fix.
I saw the thread on your troubles when searching before but, while similar, the issue we are having is not the same and I doubt the fix would be either :/

It could be low on freon, could be that your efan isn't moving enough air. What efan do you have? Is it the supermod one? Or just one you got at an autoparts store? When was the efan installed?
supermod efan and it was installed in march
 

·
Registered
Joined
·
424 Posts
Was the efan installed so that it would turn on when the a/c compressor engaged?
 

·
[MTS] Who is this guy?
Joined
·
3,779 Posts
Discussion Starter #7
I would think so as it has worked just fine since March and only started just last week not working at idle. I will check after work to make sure there are no loose connections.
 

·
maniac mechanic
Joined
·
5,767 Posts
How does the temperature look when idling? I'm pretty sure the stock programming will disable the condenser if the temp is over a certain level.
 

·
[MTS] Who is this guy?
Joined
·
3,779 Posts
Discussion Starter #9
How does the temperature look when idling? I'm pretty sure the stock programming will disable the condenser if the temp is over a certain level.
I will have to keep a better eye on it but I didn't notice it getting any higher than normal. The AC won't blow cold until moving even if it is a "cold start" though.
 

·
Monkey Slut!
Joined
·
9,474 Posts
Guess I need me an Efan then cause I like balls frozen temps in my truck. :thumbup:
 

·
Premium Member
Joined
·
61 Posts
Id check if the compressor is short cycling ant idle. (kicking on and off). If it is the you are definitely low on refrigerant. Also make sure that the fan is on when the compressor is on.
 

·
[MTS] Who is this guy?
Joined
·
3,779 Posts
Discussion Starter #13

·
[MTS] Who is this guy?
Joined
·
3,779 Posts
Discussion Starter #15
Talked to super mod and figured out what was wrong. He's got me taken care of. That is why I bought the fan I did.
 

·
[MTS] Who is this guy?
Joined
·
3,779 Posts
Discussion Starter #18
The 40amp breaker blew so my fan was not getting power. Since the fan wasn't spinning at idle my ac would get warm.
 
1 - 20 of 28 Posts
Top