Chevrolet Colorado & GMC Canyon Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
480 Posts
Discussion Starter #1
For the last few days I've noticed every time I hit a bump I feel it in the gas pedal. Or brake pedal. Both hubs are good. I feel it more in my pedal and it annoys the crap out of me! Does anyone know why I would be feeling it there?
 
G

·
Guest
Joined
·
0 Posts
Hey there tysrado3,

I understand that you are seeking similar experiences from your fellow forum members to diagnose your vehicle issue. I may not be able to provide you any technical advice to help you resolve this issue yourself but please contact me if you have any lingering questions or concerns.

Jennifer T.
GM Customer Care
 

·
Registered
Joined
·
1,030 Posts
When searching for info on a seized lower intermediate steering shaft (the U-joint nearest the steering rack), drivers sometimes report this symptom.
 

·
Registered
Joined
·
258 Posts
The lower slip joint in the steering intermediate shaft could also need to be lubed. It must be disassembled to put grease into the slip joint section. I managed to do it in the truck thru the wheel well. there is a write up here some where. Look under threads by me. Also certain years where under a recall on the 4x4's for the steering shaft for an upgrade.
Best of luck.
 

·
Registered
Joined
·
480 Posts
Discussion Starter #5
Well just now driving home from work I had the windows down and I accidentally hit the mute button instead of the skip button on my radio.. Then I hit a bump and hear a super loud clunk from drive side front. Well it starts getting worse it just continues to clunk louder and louder by this time I'm doing 10 mph and I'm down the street from my house. So I limp it home and ask my brother to move his car out of the drive. Well I go to put it in reverse and it won't go. Seems like the front wheel is complelty froze up! But it will roll when I'm in drive! Can anyone help me on what it might be? I have had it with this damn truck! My toyota with 400k miles never left me stranded once and this truck have left me stranded a few times!
 

·
maniac mechanic
Joined
·
5,779 Posts
A bad hub would likely throw an ABS code. I'm guessing the caliper guide pins are frozen or you have a bad caliper on that side.
 

·
Registered
Joined
·
480 Posts
Discussion Starter #7
Abs light has been on since I changed the hub cuz the cheap dura last connector doesn't fit the abs one. I don't feel like it could be either of those.. My wheel still spins freely in drive. Just reverse it seems like everything's locked ip
 

·
Registered
Joined
·
2,685 Posts
Have you tried jacking it up and spinning the tire by hand? Would definitely be the easiest way to see if it's in any kind of bind.
 

·
maniac mechanic
Joined
·
5,779 Posts
Hmm that's odd, maybe you have a cv joint going bad on the axle. They can act strange like that some times. Jack it up pull the tire and snap some pictures if you can't find anything wrong yourself.
 

·
Registered
Joined
·
480 Posts
Discussion Starter #10
We'll very very good news! It was to late last night to pull my 4runner out of the garage and move around the 6 cars we have at my house lol. So today I pulled off the wheel crawled underneath everything looked good and all of a sudden I see a bolt missing out of the caliper mount.. We'll the bolt someone came out and the caliper swung back making it sit on the inside of the rim. The caliper is fine. I've been wanting new rims so this gives me a reason to finally buy myself a new set instead of used. The fix cost me 15 bucks for the bolts and I'll be picking them up in the morning.
 

·
Registered
Joined
·
480 Posts
Discussion Starter #12
Thanks man! I was going to go buy another truck tomorrow but I guess ill give her another chance!
 
1 - 12 of 12 Posts
Top