Chevrolet Colorado & GMC Canyon Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
256 Posts
Discussion Starter #1
My dad has been driving my truck the past couple days and yesterday he said going down the freeway that it felt like it was lagging and was low on transmission fluid. I got under the truck and noticed some fluid on the oil pan so I cleaned it up and drove it around the neighborhood but didn't hear or feel anything abnormal. The fluid on the dipstick was the red color and on the pan it was a brownish color but there was mud on there so I couldn't tell if it was transmission or engine oil. Seems like I fix one thing then something else goes wrong.. One more question, it's an 06 with 91,000 miles would I be covered under that 100,000 tsb for the head issue even if i don't have warranty? Don't know if the previous owner ever took it in
 

Attachments

·
Premium Member
Joined
·
5,710 Posts
Re: Another dam leak

I think the head warranty was 7years/100k. I'm pretty sure all warranties have since expired based on build dates.
I THINK it was 7 years.

In addition to the leak, your head is failing now too?
 

·
Registered
Joined
·
256 Posts
Discussion Starter #3
Re: Another dam leak

I think the head warranty was 7years/100k. I'm pretty sure all warranties have since expired based on build dates.
I THINK it was 7 years.

In addition to the leak, your head is failing now too?
Not too sure about the head but I had the spark plugs replaced last week cause there was water in the first coil but the mechanic said it might have been from me washing the engine too much with high pressure. I still haven't fixed the dtc P0446 but I'm gonna take it back by the mechanic tomorrow so he can try and trace the leak
 

·
Premium Member
Joined
·
5,710 Posts
Pressure washing the engine isn't a terrific idea.

What are the symptoms that lead you to think the head is bad.....

The for sure tell tale test is a leak down test.
 

·
Registered
Joined
·
256 Posts
Discussion Starter #5
Pressure washing the engine isn't a terrific idea.

What are the symptoms that lead you to think the head is bad.....

The for sure tell tale test is a leak down test.
Yeah I was just trying to get all the mud off the engine and had a jet stream going.

The cel came on and threw P0301 a misfire in cylinder one but I'm guessing that was from the water that got in from pressure washing] the engine. It would also idle really rough and seemed to hesitate when accelerating from a stop but it hasn't done it as bad since replacing the plugs. I'm wondering if that could be attributed to the vent solenoid malfunction too
 
1 - 5 of 5 Posts
Top