Chevrolet Colorado & GMC Canyon Forum banner

1 - 17 of 17 Posts

·
The Butcher
Joined
·
322 Posts
Discussion Starter #1
Here is another "my window and door locks don't work'' thread. About 2 years ago they stopped working. Wasn't sure if anyone figured out a actual fix. I've tried everything! The door locks from the drivers side don't work, the mirror controls don't work and the drivers side window don't work. Thinking I need a BCM. But is this something i can buy off eBay, Plug and play or do i have to bring it to the dealer? Could it be the doors switch's? I dunno..just very frustrated!
 

·
Premium Member
Joined
·
19,139 Posts
It says you have tried everything, but what is everything?

Have you tried to reset the BCM?

Have you tried leaving the battery unhooked overnight?

Have you swapped out the controls on that side to make sure the switches aren't dead?

What is everything?
 

·
GOD BLESS OUR TROOPS
Joined
·
1,553 Posts
I have a problem like this it has been very cold in the north east and just recently the window and lock switch dosnt work but the mirror switch does. If i disconnect the cables how long ? just for the nite ?
 

·
The Butcher
Joined
·
322 Posts
Discussion Starter #5
By everything i mean all the no cost tricks. Unhooking the battery, touching the cables together, unhooking the bcm, checked the wires in the door..etc etc. Haven't replaced anything yet but the battery. I was going to try the switches first but yesterday my power mirrors stopped working so now I'm leaning toward the bcm. I just didn't want to do the process of elimination and spent a lot of money when it was something simple I might of missed.
 

·
The Butcher
Joined
·
322 Posts
Discussion Starter #6
UPDATE! Since my last post a week ago I unhooked my battery and left the cables together for exactly 1 week and this morning i went out and hooked everything back up and to my surprise everything worked BUT my drivers side window! Sooo how do I solve this? How can I test my motor? Will it fit in other side or back door? Or is there a way to test the switch?
 

·
Premium Member
Joined
·
441 Posts
UPDATE! Since my last post a week ago I unhooked my battery and left the cables together for exactly 1 week and this morning i went out and hooked everything back up and to my surprise everything worked BUT my drivers side window! Sooo how do I solve this? How can I test my motor? Will it fit in other side or back door? Or is there a way to test the switch?

Front left and right are different regulators. Don't know for sure, I have an extended cab, but the same probably holds true for rear seats being different based on the size of the doors in my opinion.

Since there are only 2 wires hooked up to the motor, I would try running a lead to I would guess the brown. Be real careful, first time I played with a regulator years back, game myself a nasty cut when I energized it.
 

·
Premium Member
Joined
·
441 Posts
UPDATE! Since my last post a week ago I unhooked my battery and left the cables together for exactly 1 week and this morning i went out and hooked everything back up and to my surprise everything worked BUT my drivers side window! Sooo how do I solve this? How can I test my motor? Will it fit in other side or back door? Or is there a way to test the switch?
Forgot: I'd start by checking for voltage at the connector near the motor.
 

·
The Butcher
Joined
·
322 Posts
Discussion Starter #9
just tested the motor to the battery and it works! so must be the switch...thanks Rick!
 

·
Premium Member
Joined
·
5,710 Posts
Disconnect battery again. Yes I am serious.

I have yet to disconnect my battery and reconnect it without error. EVERY time I connect it, something doesn't work properly.

For me it is usually, the speedometer that doesn't doesn't work. The gear selector indicator is stuck on D. The shift points are wacked out. And the engine light comes on and I get a "U" code (failure to communicate blah blah). After a 2nd, or 3rd connection things begin to work properly.
All of those happen every time. But I can easily drive down the road with a truck that doesn't shift at speeds I'm unaware of and puff's out black smoke while rolling up and down my windows. LOL
 

·
Registered
Joined
·
60 Posts
I took mine to the dealer for the same thing but my mirrors worked. They found that there was a short in the window switch. I replaced it Thursday and it has worked since. It cost me about 127 with 2 day shipping on rockauto which was cheaper than anywhere else with standard shipping

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
376 Posts
I agree with 08canyon. Every time I disconnect this thing to do something, I reconnect it and something's fucked up. Right now it's my speakers, door locks, windows, lights, the whole shebang... I'm leaving it disconnected overnight and hoping it works in the morning.
 

·
The Butcher
Joined
·
322 Posts
Discussion Starter #13
I got this far I'm probably NEVER unhooking my battery again!! But I noticed my switch doesn't even light up so I ordered a new one.
 

·
Registered
Joined
·
102 Posts
Not to resurrect an old thread, but both my mirrors stopped working about a month ago. Searched the fuse box, and not finding a dedicated fuse, I began searching here. Going to try the battery disconnect tonight. We'll see how it goes.
 

·
Premium Member
Joined
·
2,761 Posts
The wiring diagram shows power coming from the "TRN/HAZRD FRT" 15amp fuse. The circuit goes through the BCM before continuing to the door.
 

·
Lifetime Member
Joined
·
723 Posts
Happens every time I unhook the battery.
I pull the negative wire from the battery.
I pop the switch from the passenger door, unplug the wire connectors. Hit all connections with contact cleaner.
Put it back togather
Reconnect the negative terminal and it works.
Has never helped to disconnect the battery and wait as long as a day without cleaning those connectors.
Craig
 

·
US Army 19yrs and ......
Joined
·
45,284 Posts
Why all the problems with disconnecting the batteries guys????

Have yall checked all of your grounding points.....and or cleaned? The BCM does not like bad grounds....this has been the simple solution to alot of issues here
 
1 - 17 of 17 Posts
Top