Chevrolet Colorado & GMC Canyon Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hello! Some of you may remember I posted a thread awhile ago about a p0171 code that my truck kept throwing along with hesitation, stumbling while increasing speed. After replacing MAF, plugs, air filter, o2 sensor, checking for vacuum leaks and fuel pressure I was not able to diagnose. Therefore I have scheduled an appointment at the dealership for this Thursday. Hoping to fix it myself before the appointment, I had it rescanned and the truck is now throwing more codes.

p0068 - Throttle Body Air Performance
p0113 - Intake Air Temperature sensor circuit high voltage
p0102 - MAF sensor circuit low frequency

My last hoorah is to clean the throttle body? Any other ideas? One other thing after replacing the MAF sensor should I have reset the computer because I did not? Would not resetting the computer after replacing the MAF not cause me to notice the change in MAF sensors?

Thanks guys/gals
 

·
Premium Member
Joined
·
2,761 Posts
Was the replacement MAF Sensor ACDelco or aftermarket? The Intake Air Temperature Sensor is part of the MAF Sensor so those two codes (P0113/P0102) are probably related and could cause the P0068. I don't think that the MAF Sensor can be installed backwards, but check the installation and the wiring. You could have a defective/incorrect MAF Sensor

I would suggest disconnecting/waiting/reconnecting the battery and see if that changes anything.
 

·
Premium Member
Joined
·
2,691 Posts
That's alot of codes !!! Good luck finding the gremlins !!!
 

·
Registered
Joined
·
1,061 Posts
If I remember you just bought the truck correct--- I wouldn't spend a penny on trying fix anything. Have that dealer fix that shit for free or get your money back.
 

·
Premium Member
Joined
·
2,761 Posts
If I remember you just bought the truck correct--- I wouldn't spend a penny on trying fix anything. Have that dealer fix that shit for free or get your money back.
He's put 35,000 miles on it since he bought it. Not sure he will get much help in that area.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
Yeah I have put 35k miles on the vehicle, and to this point it has been great. I will try another maf. I purchased a maf at a local auto parts store, not sure if it was acdelco,
and returned it after it didn't help. Like I said I did not reset the computer during the install. I'm guessing I should try it again.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
Does unplugging your maf sometimes cause reduced power mode. After unplugging the maf the truck ran like normal but will eventually go into reduced power mode upon acceleration. This leads me to believe it's the maf sensor.
 
1 - 8 of 8 Posts
Top