Chevrolet Colorado & GMC Canyon Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I went to use my cruise control yesterday evening and it wouldn't work. My first thought was oh great another brake switch failure. When I got home I found out that the rear brake lights was working but the 3rd brake lights were out. I replaced the third brake lights, still no cruise. I did change to led replacement bulbs because the passenger brake light kept blowing. I swapped the led out with the original bulbs, still no cruise control. I checked both switches under the dash both of them test good out of the truck, reinstalled, and made sure they were adjusted properly, still no cruise. I have checked every fuse in the fuse box, all test and look good. I also took the multifunction stalk apart to make sure nothing was loose and eveything was making contact. Everything appears good.

Any Ideas Guys???
 

·
Registered
Joined
·
1 Posts
I went to use my cruise control yesterday evening and it wouldn't work. My first thought was oh great another brake switch failure. When I got home I found out that the rear brake lights was working but the 3rd brake lights were out. I replaced the third brake lights, still no cruise. I did change to led replacement bulbs because the passenger brake light kept blowing. I swapped the led out with the original bulbs, still no cruise control. I checked both switches under the dash both of them test good out of the truck, reinstalled, and made sure they were adjusted properly, still no cruise. I have checked every fuse in the fuse box, all test and look good. I also took the multifunction stalk apart to make sure nothing was loose and eveything was making contact. Everything appears good.

Any Ideas Guys???
I have same problem, ever find out any info ?
thanks
Rick
 
1 - 3 of 3 Posts
Top