Chevrolet Colorado & GMC Canyon Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3,444 Posts
Discussion Starter #1 (Edited by Moderator)
Ok so a couple little things on the truck are bugging me... lets see if anyone has experience with these problems, and if you have any input feel free to put in your 2 cents ;)

1) At about 1800-1900 RPM's there is a major resonating rattle coming from the back window between the bucket seats. When I press on the plastic wall cover it stops or if I put pressure on the window it also stops. The radio covers the noise pretty much but it's annoying and I haven't figured anything out so far. I checked the jack location and everythings nice and tight in there.

2) My A/C blower motor seems to sometimes have debris in it and sometimes not. Kinda odd but somedays it's annoying as hell and extremely loud and other days it's silent and you can't even hear it.

Is there any way to remove and clean out the blower motor or any way to clean out the debris?

3) Small misfire issue comes up maybe once every other day... I get 1 miss and then it doesnt come back for 24-48 hours. I'm running some fuel system cleaner and the trucks running a bit smoother, also got better after the TB cleaning and spraying a decent amount of cleaner into the intake manifold. I was going to go get GM top engine cleaner but it seems to be the same exact thing as what i'm using. Also i'll be ordering a new set of plugs so if I go through them and find a problem I can change it, (i'm already running denso's) but I havent checked em since installed over 30k miles ago


Thats all I can think of for now... any help would be appreciated guys :355: :salute: :355:

Wow... not even one suggestion? Damn... was hoping to maybe tackle 1 or 2 of these issues today on my day off.


Also ment to add:

4) Blower Motor resistor is f'ed... sometimes it'll be good for 5 days straight, sometimes i'll have to give the underside of the dash a good wack and it'll come back. I know the resistor needs replaced, anyone got the PN?
 

·
Registered
Joined
·
3,608 Posts
There is a TSB for the blower noise, it basically provides a cover and eliminates the noise from the motor. If you're out of warranty, there is a PN for the cover, I think its about $20.
 

·
Registered
Joined
·
3,615 Posts
i also get the rattle from the rear window. i tried rolling up some old cloth and jamming it under the panel were the panel meets the window all the way across. kinda ghetto but it works! the expanding foam would also do the trick if u feel like taking things apart and then trimming that stuff down after. im probably going to install a pad of some sorts across that whole back panel when i re-do my system.

dont have any of the other issues... yet..:(
 

·
Registered
Joined
·
24 Posts
Eh. :shrug:

As far as the plastic goes, I'd take the panel off and spray the crap out of it with blue noise killer.
 

·
Registered
Joined
·
342 Posts
on my rado, I had the same misfire thing, but it went away when I installed the denso's but you already have them... :shrug: Hmm have you cleaned the MAF? tried changing gas types? Could it be something with your tune? I am sure you already checked all that

Oh and try and find something called seafoam you can run one bottle in the tank and then use one as an intake/tb cleaner, that stuff works wonders for me

this stuff http://www.seafoamsales.com/motorTuneUpTechGas.htm
 

·
Registered
Joined
·
48 Posts
ya listen to MAV Seafoam is the BEST i also hear if you drink it it adds 2" to your P_ _ ker! just kidin.. but it is really great stuff!
 

·
Registered
Joined
·
4,682 Posts
Take the blower motor resistor out and clean it up. You'll find some burn marks on the contacts. I should last you another couple years before you'll have to clean the contacts again. Most people replace it, but cleaning it works just as well.
 
1 - 7 of 7 Posts
Top