Chevrolet Colorado & GMC Canyon Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
9,094 Posts
Discussion Starter #1
SO I've got a dilly of a pickle over here. Came out from the grocery store, started the truck and put it in gear......then the chime comes on and my cluster is flashing the "DOORS" message. So me and my girl open and close both doors again but it's still on??? WTMF!? Stayed on the whole way home. Lucky our trucks have the dome override button or else my new LED dome lamp would've gotten annoying! lol

But I'm really scratching my head on this one. It's been snowing all afternoon, then raining the rest of the day so there's alot of standing water I've been hitting. I'm wondering if some water got into the door switches and is causing this? My passanger door switch has been acting up for some time now. When I open the passanger door, the interior lights don't come on unless you "jiggle" the switch. Then they'll come on but usually go back out.

Although, you know how when you turn the truck off and the radio/windows/wipers etc.. stay on till you open the drivers door? I can't remember, but does that go for the passanger door too? Cause when I turned the truck off after I got home, everything shut right off....like the drivers door was open, which leads me to suspect the problem lies in the drivers door switch?



Anyone else have this problem? Any suggestions?
 

·
Registered
Joined
·
9,094 Posts
Discussion Starter #4
That's what I thought it was like on our trucks.

Some GM's I work on at work are different though. Like if I'm working on the passanger door, and I have to turn the key on to roll down the window, then turn the key back off......I'll have to reach over and open and close the drivers door so the radio will go off. Recently a Malibu Maxx I did was like that.
 

·
Registered
Joined
·
9,094 Posts
Discussion Starter #5
Im guessing that the switch is the problem
I had that happen on my 1st Colorado 2 days after I got it...I just pushed the hell out of the door switch a few dozen times with my finger and it resolved it...I'm not saying that's the correct way to go about fixing the issue...but that's what fixed my ordeal, haha....

Which switch do you guys think it is then? Which switch did you have to play with Econo?
 

·
Registered
Joined
·
9,094 Posts
Discussion Starter #7
Maybe I'll just buy the passanger switch and see if it does anything. It needs to be replaced anyway. Or maybe it does in fact have something to do with how wet it's been around here and it will "dry out" over night.
 

·
Registered
Joined
·
9,094 Posts
Discussion Starter #9
**Update**

Started the truck up this morning and closed the door......message went off! Hasn't done it all day today. Everything seems back to normal BUT, when I hit the lock button on my key fob....the horn beeps a few times like it does when you try to lock it when a door is open. But then I hit it again and then it locked? So I don't know what that's about.....
 

·
Registered
Joined
·
9,094 Posts
Discussion Starter #10
**Last Update**


Figured I'd post up one last time in case someone has this problem and finds this thread.

It went away for a while there, but started back up again last week. I unplugged the pass side switch and it went away so that was it. I ordered one up shortly there after. My cost was like $5.55...lol

Did the trick though, so if anyone has this problem....there ya go! :salute:
 

·
Registered
Joined
·
1,081 Posts
spray WD40 into the switch it will do 1 of 2 things displace the water in it or lube it up and start workn again or diconnect the battery for like 5 min maybe that'll work
 
1 - 11 of 11 Posts
Top