Chevrolet Colorado & GMC Canyon Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
I have a 2004 Z85 crew cab Colorado. When starting up, my parking lamps illuminate (of course).... But the other day, the headlights began coming on versus the parking lamps?? Anyone have this happen? If so, what is the fix? Thanks!
Zeeman
 

·
Registered
Joined
·
2,685 Posts
Maybe the photocell that tells the headlights to come on when it gets dark, is bad. I'm just guessing though.
 

·
Darth Vader
Joined
·
5,223 Posts
Maybe the photocell that tells the headlights to come on when it gets dark, is bad. I'm just guessing though.
This is my first thought.

Do both come on now, or just the headlights? Also look for the DRL dummy light on the cluster (on the tach above the check engine light) This should be green when the DRL's are active, and off when the photocell tells the headlights to come on.
 

·
Registered
Joined
·
127 Posts
If the headlights and all 4 parking lights are on, then the truck thinks that it's dark enough for headlights. Does it constantly happen, or was it just once? I know my headlights come on if it's cloudy enough out. Would having the headlight knob turned do that? Just some thoughts.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #6
First, thanks for all the replies.....!! My green dummy light telling me the parking lamps (fronts) are on, no longer illuminates. I haven't thought yet to check and see if the rear lamps are on when first starting up... I will do that tomorrow morning! Thanks for that tip. All this began about 2 weeks ago out of the blue..... I am assuming the 'photo cell' is on the top of the dash someplace? I will check tomorrow as well and just make sure nothing is covering it making the vehicle believe its dark.
I'll update tomorrow evening....Thanks once again for all the posts....:)
 

·
Registered
Joined
·
2,959 Posts
If the auto-headlamp circuit is commanding the headlights on, you should be able to toggle from lowbeams to highbeams to lowbeams.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #8
Okay.... Problem is solved!! The wife thinking the cab wasn't smelling sweet enough, laid one of those sweet smelling packets on the dash....RIGHT OVER THE PHOTO CELL....:roll:

Removed the item to the other side of dash and all is well once again...

Thanks for all the replies!! That photocell post got me thinking!!

Zeeman
 

·
Registered
Joined
·
2,959 Posts
...The wife thinking the cab wasn't smelling sweet enough, laid one of those sweet smelling packets on the dash....RIGHT OVER THE PHOTO CELL....:roll:
...
:lol:
 

·
Darth Vader
Joined
·
5,223 Posts
Okay.... Problem is solved!! The wife thinking the cab wasn't smelling sweet enough, laid one of those sweet smelling packets on the dash....RIGHT OVER THE PHOTO CELL....:roll:

Removed the item to the other side of dash and all is well once again...

Thanks for all the replies!! That photocell post got me thinking!!

Zeeman
That's what we're here for :thumbup:
 
1 - 10 of 10 Posts
Top