Chevrolet Colorado & GMC Canyon Forum banner

1 - 20 of 34 Posts

·
o.g.
Joined
·
3,412 Posts
Discussion Starter #1
Well had to take it to the dealer, when I pulled out to go to work I was dragging one wheel. It was very cold last night and I could not get it to release this morning. I ended up driving to work once it let go a little (less than a mile drive) then took it to the dealer. (down the street from work). They said the cable came loose from the thing thats holds it. (forget what they called it) so they put it back together and readjusted the cable. Works better than before now. I think it might have something to do with the helper springs I had....ever since I put them on and till the day I took them off they gave my ebrake problems. not sure though...

thought I would share my problems.
 

·
Premium Member
Joined
·
21,130 Posts
i wonder if there is a way to setup a e brake handle setup instead of the pedal
 

·
Premium Member
Joined
·
21,130 Posts
I hear he does drag alot :ugh:
 

·
o.g.
Joined
·
3,412 Posts
Discussion Starter #5
uh huh and you grow penises in your garden. :ugh:
 

·
o.g.
Joined
·
3,412 Posts
Discussion Starter #7
is it cold out?

when it got cold here... my e-brake stuck everyday for a week straight... you just have to let it warm up..
Yeah it was real freaking cold and it was worse than stuck. Far worse, wouldn't disengage and had 6 inches of play in the pedal after trying to move the truck.
 

·
Registered
Joined
·
528 Posts
i've just recently had the same problem but when it warmeds up it worked just fine like 2twenty2 said
 

·
o.g.
Joined
·
3,412 Posts
Discussion Starter #9
I wish mine would have, glad I am under warranty. The dealer here in town is awesome anyway.
 

·
Registered
Joined
·
528 Posts
i wish i had an awesome dealer, all of em hate me for some reason, i've had bad luck though seeing as i've had my driveshaft worked on new motor put in and several other problems due to the owner before me but they just don't like me, maybe it's cause i'm only 19 idk
 

·
Registered
Joined
·
2,931 Posts
**Parking brake** not ebrake. Its not designed to stop you in an emergency, its designed to hold you parked on a hill in case your trans comes out of park :muknow:


Just like

**Bulkhead** not firewall. Its not designed to block fire from reaching you...
 

·
Lord Bearded One
Joined
·
23,008 Posts
I had a similar problem. I set my parking break when I had the truck on ramps. When i went to disengage it the petal popped up and I though everything was fine. nope. I dragged wheel down my drive way. I stopped and looked. The bar under the truck right by the drivers door was stuck in. Grabbed a can of WD40 and blasted the shit outta it. after working it a lil it worked ok but I have yet to use it again. I a little afraid to. :shrug: Oh and it was like 70* out that day.
 

·
Registered
Joined
·
24 Posts
What's wrong with you two.

Seriously.

Any more of this bullshit and you can take a vacation for a few days.
 
1 - 20 of 34 Posts
Top