Chevrolet Colorado & GMC Canyon Forum banner

Atlas I4 I5 engine bearing issues

  • Failed rod bearing(s)

    Votes: 0 0.0%
  • Failed main bearing including thrust

    Votes: 0 0.0%
  • Rebuilt the engine

    Votes: 0 0.0%
  • Replaced the engine with new or used

    Votes: 0 0.0%
1 - 9 of 9 Posts

·
Registered
Joined
·
158 Posts
Discussion Starter #1 (Edited)
How many of you have had engine bearing problems and have had to either rebuild or replace an engine due to a failed bearing?

If so what oil and oil change frequency were you using/following?

Thanks

Note - on my 3500 - no issues yet. Some folks with the 4200 are taking out rod bearing.
 

·
US Army 19yrs and ......
Joined
·
45,284 Posts
No problems here

I have had mine since new in 04.

267mi to 9k - GM OEM conventional oil - 3k between oil changes

I ran Mobil 1 from 9k to 31k - 3k to 5k between oil changes

31k to 108k(current) running Royal Purple - 5k to 10k between oil changes

I run it like i stole it at least once a day.....drama free ownership.
 

·
Premium Member
Joined
·
798 Posts
Need a check off for no problems. I have an 07 with 111030 miles and no problems. it had 13 miles when I got it and I've used Mobil 1 since new. I change oil and filter every 10,000.
 

·
Premium Member
Joined
·
5,710 Posts
How many of you have had engine bearing problems and have had to either rebuild or replace an engine due to a failed bearing?

If so what oil and oil change frequency were you using/following?

Thanks
Which of the problems do you have?

You posed the question but didn't answer based on your own experience. Oops.

I'm around 75k and there are no ticks or knocks. I've owned it since 41k and have had the oil changed every 3,000 miles or less, until recently about a month ago when I rolled over close to 4,000 in I think about 5 months of time.
 

·
Registered
Joined
·
641 Posts
I think the OP is just doing some research.

Bearing failures are very few and far between. Almost all are caused by lack of oil for one reason or another.

I'm thrashing mine at 15psi on a daily basis. I'll let you know if anything gives up.
 

·
Registered
Joined
·
4,917 Posts
I'm at 146k with an 06 and I run pennsoil 5w-30. I run it pretty hard and still going strong.
 

·
Registered
Joined
·
1,238 Posts
Another 0-bearing owner...running M1 5w/30 Synth or Castrol 5w/30 synth and change every 5K'ish miles.
 

·
Premium Member
Joined
·
2,692 Posts
No problem here... 126k
Mobil 1 5w30w every 5500 miles...
 

·
Registered
Joined
·
2,959 Posts
Need a check off for no problems....
Agreed.

136K, usually Mobil 1 or other full-synth, premium NAPA (Wix) filters about every 6-7K.
My engine is running/driving like new, and doesn't burn enough oil to see any level change on the dipstick at oil change time. Always right on the FULL line.

I began at about 100K to carry about 1/2 liter oil for just-in-case in an aluminum bottle made for backpacking stove fuel. It's in the bed under my hard tonneau but I've never opened it.


Those backpacking fuel bottles make the perfect on-board spare oil bottle btw....
I just don't trust the thin plastic bottles the oil is packed in..
 
1 - 9 of 9 Posts
Top