Chevrolet Colorado & GMC Canyon Forum banner
1 - 2 of 2 Posts

·
Registered
2007 Chevrolet Colorado Z71 4x4
Joined
·
7 Posts
Discussion Starter · #1 ·
Hey everyone, just reaching out to see if anybody could help me with an issue I just recently have had which is a rough idle on start both cold and hot. This just happened after I installed my new cold air intake system, it threw a code running too lean for bank 1 (po171). I suspect this is due to the fact that the new intake is allowing more air into the engine and the ecu doesn’t know what to do with it so it runs lean. I just replaced the MAF sensor tonight and still ran bad. I cleared the code and am waiting for it to come back if it does. I would like to keep the intake but I’m not sure what else I could do to make the ecu relearn it’s new intake system. I’ve attached a video below which displays what I mean by rough idle Rough idle start
 

·
Premium Member
Joined
·
2,935 Posts
Hey everyone, just reaching out to see if anybody could help me with an issue I just recently have had which is a rough idle on start both cold and hot. This just happened after I installed my new cold air intake system, it threw a code running too lean for bank 1 (po171). I suspect this is due to the fact that the new intake is allowing more air into the engine and the ecu doesn’t know what to do with it so it runs lean. I just replaced the MAF sensor tonight and still ran bad. I cleared the code and am waiting for it to come back if it does. I would like to keep the intake but I’m not sure what else I could do to make the ecu relearn it’s new intake system. I’ve attached a video below which displays what I mean by rough idle Rough idle start
Secondary Air Injection properly plumbed and operating? Crankcase vent hoses connected?
 
1 - 2 of 2 Posts
Top