Chevrolet Colorado & GMC Canyon Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
528 Posts
Discussion Starter #1
so my check engine light has been on for a while mainly for the fact that i have no exhaust so it was all just emission codes coming through. well what i didn't realize is when they had to replace the stock motor at 37100 miles because the guy before me raced the truck, one of the delaersships techs apparently forgot to tighten my spark plugs down. so today we go through the check engines again due to the fact that my truck had been idling at about 4-500 rpm and got to thinking what it could be. we thought it might be the throttle body cause i guess they've been known to go bad on the trailblazers but we checked that and it was relatively clean so my next thought was just a bad spark plug. so i pulled out the first chamber and it was completly black cause the exhaut was flowing back in and igniting in the spark plug chamber for lack of better words. so i went through and replaced them all because the old ones had worn quickly because of it and then i called the dealership justout of curiosity to see what they might charge to diagnose and fix a problem like that. i think it upwards of like 2-300 for parts and labor. i spent thirty bucks and forty five minutes doing it and 15 of that was waiting on the spark plugs to get there. so just as a note to anybody if you have a problem wit ha low idle speed go to the spark plugs first.
 

·
Registered
Joined
·
7,668 Posts
so my check engine light has been on for a while mainly for the fact that i have no exhaust so it was all just emission codes coming through. well what i didn't realize is when they had to replace the stock motor at 37100 miles because the guy before me raced the truck, one of the delaersships techs apparently forgot to tighten my spark plugs down. so today we go through the check engines again due to the fact that my truck had been idling at about 4-500 rpm and got to thinking what it could be. we thought it might be the throttle body cause i guess they've been known to go bad on the trailblazers but we checked that and it was relatively clean so my next thought was just a bad spark plug. so i pulled out the first chamber and it was completly black cause the exhaut was flowing back in and igniting in the spark plug chamber for lack of better words. so i went through and replaced them all because the old ones had worn quickly because of it and then i called the dealership justout of curiosity to see what they might charge to diagnose and fix a problem like that. i think it upwards of like 2-300 for parts and labor. i spent thirty bucks and forty five minutes doing it and 15 of that was waiting on the spark plugs to get there. so just as a note to anybody if you have a problem wit ha low idle speed go to the spark plugs first.
you have a trailblazer? not to be a jerk, but this is a colorado/canyon forum. thanks for the info though, bro.

edit: sorry, just looked at your profile.
 

·
Registered
Joined
·
528 Posts
Discussion Starter #3
the throttle bodies on the colorados and trailblazers are the same so thats why we thought it might be the throttle body, thats what i was trying to say. i have a 2005 colorado z-71 regular cab 3.5 I-5
 

·
Registered
Joined
·
7,668 Posts
the throttle bodies on the colorados and trailblazers are the same so thats why we thought it might be the throttle body, thats what i was trying to say. i have a 2005 colorado z-71 regular cab 3.5 I-5
ouch. didn't know that.
 

·
Registered
Joined
·
528 Posts
Discussion Starter #5
its cool i can see why you said what you said no hard feelings
 
1 - 5 of 5 Posts
Top