Chevrolet Colorado & GMC Canyon Forum banner

1 - 9 of 9 Posts

·
¯\_(ツ)_/¯
Joined
·
5,884 Posts
Discussion Starter #1
After the truck sits for a few hours and cools off it won't start right away. It will crank for a second or two then stop suddenly and try to start again, it ground the starter yesterday when I got in it to go to work. I had the same problem last year, around summer time. It didn't do it all winter, and just started doing it again. I'm at a loss, I can't figure out what it could be and since it doesn't do it all the time I doubt the dealer would be much help. Warranty is out anyway so whatever it is I'll be fixing it myself.

Currently the truck is/has: '04 Colorado 3.5L/AT with ~39k miles. Mods are PCM4Less tune, Jet Servo, Denso Iridium plugs (I don't really consider it a mod but whatever :lol:), K&N drop in with stock intake and airbox lid removed, gutted manifold cat.

I've cleaned the MAF/TB within the past 5k miles but I'm going to clean the TB again this week to see if it helps. I'll also clean the evap line going to the TB since I've never done it. K&N was cleaned/reoiled 5-6k miles ago. Fuel filter was replaced ~20k miles ago. I've NEVER had a CEL except for the 1 time I left the breather hose going to the intake resonator unplugged.

Any idea's? I'm lost on this one. :shrug:

edit: Honestly, it almost acts like the timing is too far advanced on startup but it doesn't make sense since it's not worse when warm.
 

·
Registered
Joined
·
181 Posts
ive got an 06 I4, n' it will have a hard time starting at random times, sometimes its fine, sometimes it barely gets going. and during colder weather, it often will give me a really loud almost wind-like roar that wont go away untill after it shifts into second gear
 

·
¯\_(ツ)_/¯
Joined
·
5,884 Posts
Discussion Starter #3
ive got an 06 I4, n' it will have a hard time starting at random times, sometimes its fine, sometimes it barely gets going. and during colder weather, it often will give me a really loud almost wind-like roar that wont go away untill after it shifts into second gear

The wind like roar is probably your fan.
 

·
Registered
Joined
·
2,449 Posts
I had a starting issue when I first got my 05 i5. The dealer did a update to the PCM I believe. Never happened again. I have since got an tune and the latest GM updates.
 

·
Registered
Joined
·
3,444 Posts
Are you allowing the vehicles fuel system to prime?

When you get into the truck after it has been sitting turn the key to on and wait about 5-8 seconds for a clicking sound to come from the engine bay, then give it a start.


Thats the advice i've been given people with hard start issues and it seems to help a lot of people :)
 

·
Registered
Joined
·
2,449 Posts
I havent had the issue since the GM update. Plus when I start the truck I kind bump the key, I never really hold it there...
 

·
Registered
Joined
·
3,615 Posts
Are you allowing the vehicles fuel system to prime?

When you get into the truck after it has been sitting turn the key to on and wait about 5-8 seconds for a clicking sound to come from the engine bay, then give it a start.

yeh thats usually the simple solution.
 

·
¯\_(ツ)_/¯
Joined
·
5,884 Posts
Discussion Starter #9
Are you allowing the vehicles fuel system to prime?

When you get into the truck after it has been sitting turn the key to on and wait about 5-8 seconds for a clicking sound to come from the engine bay, then give it a start.


Thats the advice i've been given people with hard start issues and it seems to help a lot of people :)
I'll give it a shot, thanks for the info. :D
 
1 - 9 of 9 Posts
Top