Chevrolet Colorado & GMC Canyon Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter #1
so heres the scoop. Bout a week ago i was driving home and started to get a bad misfire. scanned the codes and came up multiple random and cyl 5. swapped coils and it stayed in cylinder 5. checked plug, only 20k, and changed it for the hell of it. still bad misfire. got a new tank of gas and it all cleared right up. im thinking bad tank. put a can of seafoam in just to clear it all up. weird thing is tho no of this started for the first 3/4 of that tank. anyway been running good again until today. im down to a 1/4 tank again and she wont accelerate. i floor it and she go til about 3,000 rpm then bog back down like its hitting the rev limiter. i can get it up to whatever MPH i want but no fast accel. neutral she will rev up to 4k before bogging back down. no check engine light and engine is running smooth as can be. i disconnected the battery all day at work so the computer can reset and start over again. any other suggestions??
 

·
Registered
Joined
·
83 Posts
Discussion Starter #4
ok so after letting it sit with battery un hooked for the day it was still acting up. well being down to a 1/4 tank i filled up. now its perfectly fine. so its only happening when im down to 1/4 tank... now im really confused :wtf2::wtf2:
 

·
Registered
Joined
·
1 Posts
Mine was bogging like that 2 weeks ago... It was my upper cat. Once that failed, it heated up and then cracked the manifold.

Outside the box on the thought, but worth checking out
 
1 - 7 of 7 Posts
Top