Chevrolet Colorado & GMC Canyon Forum banner

1 - 20 of 33 Posts

·
Premium Member
Joined
·
857 Posts
Discussion Starter #1
for you tuning gurus out there: I decided to move my maf from a 3" tube to a 3.5" tube, almost identical location that it was and distance from the TB. the air is also hitting it the same and I cant get it dialed in for the life of me. It says it wants fuel so I add to the maf table the error percentage(mult. % by half so it isnt over done) and then it wants fuel pulled, so I pull a little and then it wants more. Im not sure whats going on but Im about to drive it off a cliff, which may not be possible. i ordered another maf from the parts store and was gonna try that to see if it made any difference, but that wont be till wed. I have never had this much issue getting a Maf sensor dialed in. Ive also noticed that the spark is ALL over the place, not sure if its in response to the fluctuating rpm trying to correct spark for under/overspeed or what. the maf readings on my chart display(hptuners) has a little bit of squiggle at idle but doesnt seem too bad. any insight is helpful
 

·
maniac mechanic
Joined
·
5,779 Posts
Have you modified the MAF harness at all or is it still the factory loom? My best guess would be a small leak around it, something with the wiring, or a bad sensor. I'm sure you would have the proper histograms and everything by now so I doubt you have anything wrong there with the error calculation.
 

·
Premium Member
Joined
·
857 Posts
Discussion Starter #3
I did modifiy(extended) the wiring 2 yrs ago when i first put the supercharger on and never had any problems. Maybe I need to check it over again. Maybe check for 5v reference and a good ground at the pigtail. Gonna try and reseal around The MAF bung when I try the new sensor...
 

·
maniac mechanic
Joined
·
5,779 Posts
Yeah that could mess with it if the wiring is not the same gauge and there isn't a good connection. Always solder sensor connections as well if you didn't already.
 

·
Registered
Joined
·
868 Posts
doesSound like you may be pulling some fresh air in downstream from the maf,at least that is exactly the way mine acted when that was happening.
 

·
Premium Member
Joined
·
857 Posts
Discussion Starter #7
I checked all the wiring(yes fixxer I did solder it when I first did it) and it looks ok. I am wondering though if where the wires go into the connector are maybe tweaked/weak cuz they have spend most of their life somewhat bent over to the side and its been plugged in and unplugged who knows how many times... Ill get some logs after I double check everything and put the new sensor in wed. it would be nice if it were just some small air leak post MAF. we will see. thanks all
 

·
Registered
Joined
·
832 Posts
In my experience...
After you do a rough scale for diameter you'll need to pull a TON of fuel out of the 1-10 lb/min area. It's definitely not a linear change.
 

·
Premium Member
Joined
·
857 Posts
Discussion Starter #10
Ya I'm not real good with math. How would i figure the scale since I changed the tube dia.?
 

·
Registered
Joined
·
2,686 Posts
if i changed from 3.5 to 4" air tube would i need to adj my maf ?
it's in the air box on a 5.3 ahead of the tube
 

·
tinja nurtles
Joined
·
11,837 Posts
The maf housing on the 5.3 is around 3.5" and its built into the air box.

Changing the pipe afterwards would not have near the effect on it as changing where it mounted.

What size tb is on the 5.3?
 

·
Registered
Joined
·
832 Posts
Ya I'm not real good with math. How would i figure the scale since I changed the tube dia.?
A = pi D^2/4

The percentage change is A2 / A1 - 1

Everything falls out of the equation except D2^2 / D1^2 - 1

If you went from 2.75 to 3.5 it would be 3.5^2 / 2.75^2 - 1 = 12.25 / 7.0675 - 1 = 0.733 or 73.3%
 

·
Premium Member
Joined
·
857 Posts
Discussion Starter #15
so what would it be if I went from a 3" to 3.5" please? :) do I subtract that percentage or add it?
 

·
Premium Member
Joined
·
857 Posts
Discussion Starter #17
LTFT & STFT are sitting at 0% while trying to calibrate the maf.
 

·
Premium Member
Joined
·
857 Posts
Discussion Starter #19
kk I will have to add 36% to my original maf tuning file cuz I already done screwed the current one up trying to get it to run right lol. so it needs 36% more fuel? I figured that it would need less fuel since its not "seeing " as much air since more is moving around it with a larger tube... I hadn't planned on touching the VE tables
 

·
Premium Member
Joined
·
857 Posts
Discussion Starter #20
heres the way it was the other day when I first tried getting it to run right without a new sensor/scaling it properly, etc. I will get a new log once I reseal the maf bung with new sensor in it and apply the 36% scaled(added) values into the table. thanks guys
 

Attachments

1 - 20 of 33 Posts
Top