Chevrolet Colorado & GMC Canyon Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I know I haven't been on this forum much (spending most of my time fiddling with my m/c) but recently, I've begun having a wierd problem with my 2007 LS w/the smaller four cylinder engine. After driving for awhile, and letting the engine sit (usually an hour or so, but this last time only long enough to fill the gas tank), when I attempt to start the engine, it will crank and crank, but won't start. After letting the truck sit for a while, the next time I try to start the engine, it does! After the second time this happened, I took the truck to the dealer, who first diagnosed the possible culprit as the fuel pump ($$$). After keeping the truck overnight, testing the fuel pump for pressure etc. , the mechanic was unable to duplicate the problem. The next morning after I retrieved the truck from the dealership, after driving 30-40 miles, I stopped to fuel up the truck. After completing this task, I attempted to start the engine and the same thing occurred-the first time this has happened in such close proximity to the last failure. Has anyone experienced this problem, and if you did, what was the final diagnosis?
 

·
Premium Member
Joined
·
5,710 Posts
Seems several experience something similar.

But before people go in the direction of a sesnor, like temp sensor -have you noticed if the passlock system is engaging? That is evident by the truck icon with a padlock over it lit up on the dash. That is GM's anti theft and often will react as you have described. The vehicle will start 10 minutes later when passlock has been triggered.
 

·
Registered
Joined
·
1,235 Posts
^^^Another bet on Passlock fail^^^
 

·
Registered
Joined
·
380 Posts
if your security light is flashing on the dash w hile your cranking then it's a passlock issue.

best thing to do is send your PCM in to limeswap for a tune and disable VATS.
 

·
Registered
Joined
·
278 Posts
if your security light is flashing on the dash w hile your cranking then it's a passlock issue.

best thing to do is send your PCM in to limeswap for a tune and disable VATS.
or just CUT THE DAMN WIRE!
 

·
Registered
Joined
·
808 Posts
If its the antitheft activating and your missing your keyless entry. I recommend you order then on amazon and have them programmed by a locksmith. I got two controls done for 45 and now as long as i unlock with remote i have no issues. I also had to replace my door switch sensor that tells the truck you have opened the door. I just swaped it with the good one from a rear door..lol
 
1 - 6 of 6 Posts
Top