Chevrolet Colorado & GMC Canyon Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey guys I just picked up my 2008 Colorado 3.7 i5 today. I've been really excited to get it. The truck has 170,000 miles and is in pretty good shape for that amount of miles. After driving it all day the CEL came on and I get two codes. P0014 and C0899. The truck runs fine. Has some vibrations and stuff but nothing serious. Has good power and idles great. Also I have a problem with when I switch between 4WD and 2WD the light will never go solid. Just blinks regardless of what button I press. It does change though from 4WD to 2WD just the light never goes solid. Noy sure if that really matter. I have tried everything the manual says and everything I can find online here. I plan to check on the variable valve timing actuator tomorrow and see how the screens look for the p0014 code. I'm not sure what to do about the other one. Maybe get a new battery idk. Well I hope to learn a lot from you guys any advice would be appreciated. Any members from around western Kentucky lmk thanks

-Adam

Car Automotive parking light Tire Wheel Land vehicle

Car Wheel Automotive parking light Automotive side marker light Land vehicle
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Thanks guys. I went to bed with all those problems I described. Woke up this morning the CEL is off and my light on my 2WD is on solid. Not sure what the CEL going off but idk..
 
1 - 10 of 10 Posts
Top