Chevrolet Colorado & GMC Canyon Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter #1 (Edited)
Hello, this is Lucio. I am a new member to this site looking to make new friends who will hopefully share their knowledge with me. I will start off by saying that I am NOT much of a mechanic although I have managed to fix some problems on my own vehicles in the past.

I am the proud owner of a 2009 GMC Canyon equiped with a factory installed off road kit which makes it look as if it is a 4X4 but it's not. I don't like mistreating my truck by taking it off road which I guess defeats the purpose of having an off road kit on it.

I am having a problem with my truck where it will not start up from time to time. It makes sort of a grinding noise at the air intake (please see the image I uploaded). The truck will then start-up after about 10 to 15 minutes after turning the ignition multiple times. I do not see any abnormal (or better said noticed) lights on the dashboard. Can someone please help me figure out what this could be.

-Lucio
 

Attachments

·
Premium Member
Joined
·
86 Posts
First, welcome to the nation from a fellow Texan. Second, sorry but cant help ya with the problem. good luck tho, many extremely knowledgeable people on this site.
 

·
Luv them hoochies
Joined
·
3,336 Posts
Welcome to the forum
If ur truck isn't starting for 10-15min it could be a pass lock issue a lot of our trucks have this problem how many miles do u have
I'm sure some more knowledgeable people will chime in but I would ask either @limequat or @Supermodulation
 

·
Registered
Joined
·
0 Posts
Discussion Starter #4
Thank you for the quick reply djdrek/t-bone. The truck has 76581 miles. I will take your advice and get with limequat and supermodulation. I appreciate you all.
 

·
Premium Member
Joined
·
441 Posts
:welcome2:
 
1 - 14 of 14 Posts
Top