Chevrolet Colorado & GMC Canyon Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
824 Posts
Discussion Starter #1
So I put my stock intake back in my truck Thursday then today Friday I took my headliner down so I can reopholster it. Well I jumped in my truck to leave work tonight going down the road I notice when I push to put my high beams on they won't work plus I don't have lights on my climate knobs and the hazard lights won't turn on. I noticed once I press the high beams back like I'm going to flash them they turn on while holding it. When I do that all the things I mentioned that didn't work turned on but once I let go of the high beams they shut off?
Dose anyone have a clue what's up?
Thanks
Dave
 

·
Premium Member
Joined
·
5,710 Posts
Disconnect again. Leave off for an hour. Reconnect to see if it's fixed.

Often time, reconnecting the battery makes stupid stuff happen. The BCM get confused when the power is reconnected and it arcs.
 

·
Registered
Joined
·
824 Posts
Discussion Starter #5
Ok I'll have to try that I only had the battery unplugged last night only for about 10 mins with no luck
Thanks
 

·
Registered
Joined
·
824 Posts
Discussion Starter #6
So I tried unpluggung the battery for an hour or so with no luck. What makes no sense when my headlights are not on I have hazard lights but once I put the headlights on nothing until I pull back on the high beams then I have them and lights to the heating fan knobs. I'm totally pissed now and have no clue what to do
 

·
Registered
Joined
·
824 Posts
Discussion Starter #7
Well unplugged both positive and negative battery cables last night and hooked them back up this morning issued fixed lol these damn trucks I tell you
 
1 - 7 of 7 Posts
Top