Chevrolet Colorado & GMC Canyon Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2009 with the 3.7 that I bought with a rod knocking motor and I rebuilt the engine and installed it but when i started it found out I had a bad crank position sensor because there was no reading on my scan tool. It ran but rattled a little if I tried to rev due to "from my understanding" the timing couldn't adjust properly without a reading. It ran for a few minutes then died and after I replaced the faulty sensor will still not start so during problem shooting I determined that there is now no signal from the ECM to the coil on any cyl. I have checked all wires from the coils to the ECM and all have continuity so I am curious if I could be missing something or does it sound like the ECM either needs to be flashed or replaced?
 

·
Registered
Joined
·
68 Posts
I'm not sure if this will solve all your problems, but our trucks need a ECM Re-learn after installing a new crank position sensor. This has to be done with a GM tech tool so either a dealer, or large shop that has the tool. As far as i've read, this wont prevent starting the engine so the coils not getting power is probably unrelated. Do you have any codes or other dash lights such as the Pass-Lock symbol flashing?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
No codes at all are showing up and the passlock is not activated either. I planned on doing the relearn once I get it running again. Thanks for any and all ideas.
I would like to find the ECM pin out for the 2009 with the 3.7 to check other circuit feeds going to and from the ECM in case something isn’t getting power or ground as it should be.
 

·
Registered
Joined
·
68 Posts
I also ordered a cam position sensor from Amazon and it bolted in and plugged up but it was the wrong one and I had a no start condition. Just in case that helps
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
I replaced the cam position sensor and the exhaust camshaft solenoid too but believe they are both working correctly.
 
1 - 5 of 5 Posts
Top