Chevrolet Colorado & GMC Canyon Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
No start on 2.9l i4 GMC Canyon 2007. I have tried replacing the battery it deffenitly cranks faster but I know it won’t start in the anti theft mode. Its also -30 here never had an issue and I’m at 230000km drive it last night to my buddies house about 10min away and then it decided not to start this morning. The pass lock is on and solid in color. I have codes of u1064 and c0899 not sure if this relates to my issue and I have tried my 3 keys And have with no luck to start with either. I’m thinking it’s the ignition switch but if the codes are doing something else much help would be great. I have tried 10min with switch on and 30sec off but I have read others even with success it has needed to be done every start talking up to 40min! Any help out there so I can save some $ from the thieves at the dealer??
 

·
Registered
Joined
·
1,251 Posts
Here's what I see for your codes:

The code U1064 is a loss of communications with DIM, usually caused by loss of power to the Body Control Module. It can be caused by an ignition switch going bad or loose battery connections.
C0899 That code is an ABS code. Its sets anytime the battery voltage is below 9 V for 100ms in the EBCM(electronic brake control module). That code will not turn the check engine lamp on.

I don't know what to tell you man. Looks like time for an ignition switch.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Sounds good I spoke to Napa and I will have the ignition switch tonight and will give it a try. Not excited for this -30 repair🥶
 

·
Registered
Joined
·
2 Posts
Sounds good I spoke to Napa and I will have the ignition switch tonight and will give it a try. Not excited for this -30 repair🥶
Just replace the switch located at the bottom of the assembly. You can do this without removint the lock assembly. Just remove the clamshell plastic cover at the base of the steering wheel, remove the switch from the new assembly and put it on on place of the old one. Worked on my 07.
 

·
Registered
Joined
·
30 Posts
Hope that works out for you. Please update. I have same year and engine Colorado. I had this problem for a while. Was quite a nuisance, late to work, etc. Different, newer, better quality key helped but then I also had the passlock feature removed during my last mail order tune several years back and never saw this issue again.
 
1 - 6 of 6 Posts
Top