Chevrolet Colorado & GMC Canyon Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
alright i have a 04 canyon 3.5 auto....i wrecked it couple years back and overheated it.... since then i have noticed that when i change the oil only like 2.5 quarts come out of the truck when i put six in it.... i use synthetic penzoil platinum..... have for years... i just thought since i overheated the engine it was probably burning oil now....... but the other night i was looking under the truck and saw that one of my fuel lines had oil all over it.... i looked above it and saw a black hose kinda like an overflow or something,, it had oil all over it as well....i traced it.... it runs beside the transmission then up to the engine....looks like it connects to the engine around the firewall....at the point of connection there is wet oil there........also this hose is real grimy looking..like it has been leaking for some time now......what is this, does anyone know what i need to do.......... also i get really bad gas mileage.....i just checked it i went 220 miles on 17 gallons.....now i am running 31.10.50s but they are wore out not much tread at all.....but doing calculations off of odometer says im gettin like 13 mpg...i know that is a little wrong because of tire size but not by alot.... i even grampa drove that tank just to try to get better mileage... stayed under 2000 rpms almost constantly.... i put new bosch plat 4 plugs in bout 4000 miles ago....also cleaned maf and throttle body regurlary...have k&n intake...new fuel filter new gas cap.... ??????? need help in multiple areas guys.....
 
1 - 4 of 4 Posts
Top