Chevrolet Colorado & GMC Canyon Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
So I have had this problem with my truck for around 10 months now. I have about a 30 min drive to work in the morning and when I get about 3 miles away from my house my trucks RPMs drop to around 1000 and I lose power. I then push the pedal to the floor and it stays at 1000 rpm. After about 30 seconds it will finally accelerate and be fine the rest of the way to work. Does this in the same exact spot on my way to work almost everyday. If my truck sits at the office all day without driving it on my way home it also does the same thing in the same spot on my way home. If I drive it during the day it does not do it at all. I have replaced my fuel pump, fuel filter, spark plugs, air filter, all within the last year. Doesn't make a difference if I have a full tank of gas or a quarter tank. Still does it. Drove it all winter and didn't have a problem. Once it warmed up the problem came back. Brought it to the shop and they said it would need a camshaft phaser solenoid. So i replaced the camshaft "actuator" solenoid which is the same thing and the problem persists. I am at a loss with this truck and could really use some help. Reading all the threads I'm going to clean the MAF and TB first.
 

·
252,000+ Miles
Joined
·
1,316 Posts
Could be a few things.

You may have a clogged Cat in your manifold, they crap out over time and can cause issues. Could also be a bad MAP sensor, or even a PCM in need of update. Have you checked the hoses from the top of the block to the resonator and from the top of the block to the brake booster? could also be a vacuum leak of some kind.

Any codes? Usually that's the first place to start. It's just going to be throwing parts at the truck until you get lucky or get a code to pop up.
 
1 - 2 of 2 Posts
Top