Chevrolet Colorado & GMC Canyon Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
480 Posts
Discussion Starter #1
I've been getting a p0014 code and I inspected and cleaned the exhaust cam all the screens are in contact weren't gummed up or anything. Also cleaned the throttle body and Maf! Truck runs perfectly fun doesn't run rough or anything. I have a home made intake and I'm thinking that's the problem, and that is coming off ASAP! But just wanted to get more suggestions on what it might be. And yes I have researched before I posted this.
 

·
Premium Member
Joined
·
2,761 Posts

·
Registered
Joined
·
480 Posts
Discussion Starter #3
I don't think that the intake would be responsible for the DTC P0014. If the oil level and pressure are good, it could still be the Camshaft Position Actuator Solenoid Valve. There could be an electrical defect internally sending the incorrect signal to the ECM.

ENGINE ASM-3.7L L5 PART 2 CYLINDER HEAD & RELATED PARTS. Fits: CANYON 2WD, CANYON 2WD Crew Cab, CANYON 2WD Extended Cab, CANYON 2WD Regular Cab, CANYON 2WD Z71 FLEET, CANYON 2WD Z71 SL... | Nalley Buick GMC Brunswick[

Yeah it could. But I've had 2 CELS since I put that on. And it's either lean misfire or this one. But the truck runs fine. You would think it would run rough. Atleast I would but it doesn't. But I think I'm just gonna order a new one and take off that intake. Thanks for the link.
 

·
Registered
Joined
·
85 Posts
Jus went through this last week. Replaced the sensor first, and code set again. Replaced the actuator, and solved the issue., and the screens were clean. Your intake isn't the problem.
 
1 - 4 of 4 Posts
Top