Chevrolet Colorado & GMC Canyon Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
519 Posts
Discussion Starter #1
Hey guys, some of you seen pics of the OBX header I posted on facebook. Okay here the issue I replaced the exhaust manifold with a header. I replaced my bank 1 sensor with a new one (oem) and I'm still throwing that code... I put a non Fowler to space out the sensor (used 2) and it's still throwing a cel. It usually kicks on after a day or 2, I need to get my inspection sticker, they wont pass it because I need to put about 100 miles on it to clear, but I can't because it will throw the code. I don't know if it's even caused by the header or is it something else? I know it's for emissions... I don't know what else to do.. any help is appreciated, thanks.
 

·
Registered
Joined
·
1,061 Posts
I used 2 non foulers for the second (under the truck) o2 sensor. This is how I stacked them in the pipe. Stock fouler--modified drilled out fouler-- then the o2. Worked for the 2008. Is your set up the same?
 

·
maniac mechanic
Joined
·
5,779 Posts
The first o2 sensor you leave alone, you want the non fouler on the second o2 sensor. If you spaced out the first it will certainly throw a code because it uses that for fuel calculations and it must be in an uninterrupted exhaust flow to read properly. The second is for emissions.
 

·
Registered
Joined
·
519 Posts
Discussion Starter #4
:355group:
The first o2 sensor you leave alone, you want the non fouler on the second o2 sensor. If you spaced out the first it will certainly throw a code because it uses that for fuel calculations and it must be in an uninterrupted exhaust flow to read properly. The second is for emissions.
Thanks man I will try that!
 
1 - 4 of 4 Posts
Top