Chevrolet Colorado & GMC Canyon Forum banner

1 - 13 of 13 Posts

·
Premium Member
Joined
·
86 Posts
Discussion Starter #1
I cant get my passenger headlight to light up, the bulbs are good and the ballast are good. Im at work right now and cant check anything at the moment but i thought that maybe someone else has had this problem and can give me someone to start looking?

Thanks in advance!
 

·
Retired and Sleeping Late
Joined
·
337 Posts
Since you said ballast I assume you're running HIDs.

Have you tried flipping the headlight connector where it plugs into the ballast? Our trucks are opposite when it comes to headlight power polarity.
 

·
Registered
Joined
·
1,238 Posts
Any previous issues w/this light...is it an aftermarket upgrade...new/old problem...I could go on.

More information would help aid your quandary...thks!
 

·
Premium Member
Joined
·
86 Posts
Discussion Starter #5
ok before i put in the HID kit i noticed that the passenger headlight would always decide when it wanted to work, i would start it and it wouldnt work, let it sit for a little while and next time i start it it works fine. i checked multiple fuses and they all looked good. as far as flipping it i will have to try that after work.
 

·
Registered
Joined
·
1,238 Posts
Thks...seems like a wiring/feed issue. Trace the harness/wiring backward and check continuity, damage, etc. Got to be something quirky going on w/your connection(s). Electrical gremlins suck, but persistence pays off.
 

·
Premium Member
Joined
·
86 Posts
Discussion Starter #8
yea just finding time off from work is a pain lol, but yea will do, thanks for all the help guys hopefully i can get out to it today after work and maybe start looking at it, we shall see ill let yall know what i find
 

·
Registered
Joined
·
1,669 Posts
open the hood and follow the wires there is only about 3.5 feet of wiring from the light to the under hood fuse box. there literally is 2 connections. one at the light and the other goes in the box. if its not the head light plug, then you will have a bit more time to unscrew the fuse box flip it over, undue the headlight harness check the plug, and either replace or reinstall.

im going off memory, so if i miss something dont shoot me
 

·
Premium Member
Joined
·
86 Posts
Discussion Starter #13
i took the fuse block apart and inspected everything, it all looked good so i ran all the wires and all the wires looked good as well. im picking up a multimeter tmorrow after work so im going to check every possible place i can.
 
1 - 13 of 13 Posts
Top