Chevrolet Colorado & GMC Canyon Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter #1
Hey guys

Ive been at school again for a while now so I havent been able to mess with or even drive my truck. I got home for spring break and found that my engine light has come on since I left. I got the codes read and this is what I got:

C0035 (Left Front wheel speed sensor)
C0040 (Right Front wheel speed sensor)
C0899 (Anti lock device 1 low voltage)
U1064 (lost communication with body control module)
P0128 (Thermostat coolant temperature below operating temp)
P0719 (Torque converter/brake switch circuit low)

When I get home in a few weeks my friend and I will change out the thermostat and water pump. That should solve that problem.

My questions are 1) what does the U1064 code have to deal with and is it connected to the ABS codes 2) Is the C0899 code related to the other C codes and 3) what are the common problems with the wheel speed sensors?

Ive done my research and havent turned anything up very definitive so Im at a loss with what to do on the first four codes. Thanks guys.
 

·
Registered
Joined
·
2,517 Posts
Good luck man. May want to post this to the whole forum to get more help than just the Carolina guys.
 

·
Registered
Joined
·
133 Posts
Discussion Starter #3
Yeah I'm about to. Just hate getting bashed for asking questions haha.
 

·
Registered
Joined
·
2,517 Posts
They will get over it. This seems like one that isn't a fairly common thing.
 

·
Roll Damn Tide!
Joined
·
631 Posts
How is the battery? I only ask cuz it seems it due to a electrical issue.

I've had some minor electrical issues and I did the Big 3 upgrade and they seem to disapper.

Just my 2 cents
 
1 - 6 of 6 Posts
Top