Chevrolet Colorado & GMC Canyon Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
So last Sunday I purchased a 2005 crew cab z71 and I finally got to pick it up yesterday after the dealer did a tune up, alignment and fixed some other things. The problem is today driving to work I noticed a horrible rattling noise on the drivers side somewhere. The noise is only when I accelerate, nothing when I turn or go over bumps. I tried to look for anything loose when I got home but it was dark and I cant find anything, so I was wondering if anyone has had a similar problem and knows what it could be

Thanks
 

·
Premium Member
Joined
·
4,435 Posts
Belt tensioner is on the pass side and I doubt it would make noise under throttle. Mine did the same and would make a clicking noise during idle only.

Op did you check ujoints???
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Belt tensioner is on the pass side and I doubt it would make noise under throttle. Mine did the same and would make a clicking noise during idle only.

Op did you check ujoints???
the dealer I bought it from replaced the ujoints and some other suspension parts and the weird thing is is that the rattling is gone and now there is a clicking noise when I accelerate but anyway the dealers mechanic is looking at it tomorrow since it is under warranty so I guess I will find out
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Where is the sound coming from? Under the hood or under the truck?
I believe it is from under the truck somewhere near the left front tire but it is really hard to tell sometimes but I have a mechanic looking at it tomorrow so I'll know for sure
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
Well problem solved I guess the u-joints were never replaced so that is what it is. Luckily for me its under warranty so they're going to send the entire driveshaft out to get rebuilt and replace the u-joints
 
1 - 9 of 9 Posts
Top