Chevrolet Colorado & GMC Canyon Forum banner
1 - 20 of 38 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hey. I'm new to this forum and to my Canyon. This may sound silly but I have read threads where it says to hold the negative cable to the positive cable to reset the BCM. My question is, do you keep the positive cable attached to the battery terminal when you do this? Thanks
 

·
Registered
Joined
·
2,694 Posts
Just disconnect the battery for a while (30 min. maybe) or if you have time maybe more, that should reset the BCM, ohh and :welcome2:
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
Thanks for the reply. I left the negative cable disconnected overnight and it didn't work. That's why I figured I would try the other method but I figured it would be better to ask a dumb question that do something dumb.
 

·
Registered
Joined
·
1,188 Posts
i have always heard to remove the negative...and to answer your question about touching the neg to the pos while the pos is still hooked up..NO NO NO!..you will have a fireworks show if you do..
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #5 ·
That's what I thought. So I touched the negative to the positive cables for about 30 seconds and it didn't work. I did install an Alpine stereo and that works great but I was only expecting to lose my chimes. I don't have On Star. I lost my driver side power window and my power locks. I must have wired something wrong. I will check it again when this storm breaks. Thanks for the help.
 

·
Formerly Metal_EMT
Joined
·
1,872 Posts
after having the battery disconnected, hook it back up and drive the truck a bit. sometimes it takes a while for it to reset.
 

·
Registered
Joined
·
225 Posts
That's what I thought. So I touched the negative to the positive cables for about 30 seconds and it didn't work. I did install an Alpine stereo and that works great but I was only expecting to lose my chimes. I don't have On Star. I lost my driver side power window and my power locks. I must have wired something wrong. I will check it again when this storm breaks. Thanks for the help.
Did you buy the module needed to keep the chimes and onstar? Windows and door locks are bcm issue, it'll pass (hopefully) it may take a few battery disconnects to get those back or just time...
 

·
Member's Technical crew
Joined
·
12,060 Posts
i have always heard to remove the negative...and to answer your question about touching the neg to the pos while the pos is still hooked up..NO NO NO!..you will have a fireworks show if you do..
You sure about that? LOL:D
 

·
Member's Technical crew
Joined
·
12,060 Posts
after having the battery disconnected, hook it back up and drive the truck a bit. Sometimes it takes a while for it to reset.


for any others who read this....this is exactly what you do. Sometimes it will take awhile. Disconnect the battery one time only!! Then just drive it. She will reset herself after a bit of time.
 

·
Registered
Joined
·
150 Posts
i have always heard to remove the negative...and to answer your question about touching the neg to the pos while the pos is still hooked up..NO NO NO!..you will have a fireworks show if you do..

how will you have fireworks if the negative cable is disconnected? It takes pos and neg to make sparks.

This process is called a global reset by gm which is done all the time. It only drains the capacitors in modules that retain memory. Your doing the same thing by leaving the cable off for 30 mins, but it can be done in 30 seconds by touching the cables together.
 

·
Member's Technical crew
Joined
·
12,060 Posts
how will you have fireworks if the negative cable is disconnected? It takes pos and neg to make sparks.

This process is called a global reset by gm which is done all the time. It only drains the capacitors in modules that retain memory. Your doing the same thing by leaving the cable off for 30 mins, but it can be done in 30 seconds by touching the cables together.
Hence why I said that...Dean was probally just doing a few things at the time...He's normally right on the ball!
 

·
Member's Technical crew
Joined
·
12,060 Posts
Told ya! Lol
 

·
Member's Technical crew
Joined
·
12,060 Posts
Dude...happens all the time to me. LOL, I try to go back and check every thread to see if I can help anyone and I tend to move to fast..lol.
 

·
Member's Technical crew
Joined
·
12,060 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #20 ·
Ok, so I installed my new Alpine stereo. I actually tapped into the accy power going to the air circulation switch right below the HU. It was pretty convenient and seems to be working pretty well. But, the driver side window and power locks still do not work. I left the negative cable disconnected overnight and also tried touching the negative to the positive for 30 seconds. I only drove the truck for about 45 minutes but it still did not reset itself. If it was the switch in the door would the other windows still work? Any suggestions?
 
1 - 20 of 38 Posts
Top