Chevrolet Colorado & GMC Canyon Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hello,
So when I turn left or right my rear tires lock up. I read a few posts and people said to change diff fluid. I just changed my diff fluid and it is still happening. I have the g80 diff. Could it be something with traction control? Or could my rear end be messed up?
 

·
Premium Member
Joined
·
3,357 Posts
Lock up like how? Dragging a tire, Popping, or what? Could be the clutches are stuck locked in the G80. What kind of oil did you put in in? No additive I hope. These do not need the additive(Friction Modifier).
 

·
Registered
Joined
·
647 Posts
As DigEm stated, did you use the correct oil? My truck did the same thing after being serviced. I read a tip that stated to do the following. Find a place where you can safely put the truck in reverse and then stab the throttle few times. It supposedly frees up the clutches. Give that a try, if you have the correct oil, it may fix the problem. It worked for me.
And make sure the vent tube isn't blocked.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
The back tires drag. I made sure I got oil without the additive. I tried the reverse thing but it didn’t work. I am pretty sure that the rear diff is toast.
 

·
Registered
Joined
·
647 Posts
I'm no expert but if you only have drag while turning, I don't suspect a serious problem. I had to repeat that process several times over a few days to get mine back to normal. You never mentioned mileage or if this was a sudden occurrence. Please let us know so others that may be able to help have more to go on. Perhaps WV Native will chime in on this as I think he has a pretty good understanding of differentials.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
So I have a little over 120k on it. Right before it happened I did a little burnout on ice then next corner I took the rear end started to drag. I thought it was something to do with traction control but the tc light doesn’t come on when it’s happening and it still does it when I fully turn off tc and stabilitrac.
 
1 - 7 of 7 Posts
Top