Chevrolet Colorado & GMC Canyon Forum banner

1 - 11 of 11 Posts

·
Bagged Bomber
Joined
·
10,954 Posts
Discussion Starter #1
Just wanted to make a post for anyone who has this issue ion the future.

I took my truck to the store the other day. When I tried to leave I I got an ABS light on the dash. Shut the truck off to see if it would go away and it would not restart. Its happened before so I knew If I just waited a bit it would restart. Got it restarted and get going home and the music was surging in and out over the radio, shut that off. The engine also started to die out but if I goosed it it would get going again. If I turned on my compressor the engine would bog WAY down. I wasnt far from home and when I made my last turn into my neighbor hood it shut all the way down. So I push it the rest of the way home It wasnt but a block no big deal.

Anyway I figured its probably my alt or battery so I pull them off and have the battery checked at vatozone but they couldnt check the alt so they sent me somewhere else. The battery said it was at 44% charge but they said we'd ahve to charge it to see if it would hold a charge. That got forgot about in the fuss to find a place that could actually test it. got the alt checked and it came back bad. FUCK. I go to a junkyard and get a new on.... doesnt fix the problem. Notice my battery was kindof bulging so I say fuck it and go buy a new one.... that doesnt fix it either FML.

I talked to supermod and he told me it was probably the battery control module. Call teh dealership and thats $87. found another thread on here that said they had similar issues and fixed it by changing the mega fuse.... $5 part...

I ordered the mega fuse cause Id rather try that then waste anouther $90 and TADAH that fixed it.

SO long story short if you truck dies and you have the "service chargsys" on your DIC try replacing your mega fuse first. Dont be a dub fuck and waste a bunch of money like me.
 

·
Member's Technical crew
Joined
·
12,060 Posts
How about...POST UP when your having ALL those issues friend. That way we could have told you BEFORE you did this to check the damn fuse! LOL had this EXACT problem on Diminoe's truck He said he tested all the fuses before I ever started..lol. After a new alt was installed and teh problem persisted i checked the damn things myself! Guess whut...mega fuse was bad. Imagine the look on HIS face...Wish I would have had a camera!! He was like oh shit! This guy is gonna be pissed! LOL I wasnt of course, but it's one of those stories you look back on and laugh.

BTW, you didn't happen to replace your fuse with one from autozone or advance did you? I looked and he looked, and the only one's we found were of higher amp rating than the 100 amp from factory. I would NOT suggest going with the higher amperage fuse as its just not safe.
 

·
Bagged Bomber
Joined
·
10,954 Posts
Discussion Starter #5
How about...POST UP when your having ALL those issues friend. That way we could have told you BEFORE you did this to check the damn fuse! LOL had this EXACT problem on Diminoe's truck He said he tested all the fuses before I ever started..lol. After a new alt was installed and teh problem persisted i checked the damn things myself! Guess whut...mega fuse was bad. Imagine the look on HIS face...Wish I would have had a camera!! He was like oh shit! This guy is gonna be pissed! LOL I wasnt of course, but it's one of those stories you look back on and laugh.

BTW, you didn't happen to replace your fuse with one from autozone or advance did you? I looked and he looked, and the only one's we found were of higher amp rating than the 100 amp from factory. I would NOT suggest going with the higher amperage fuse as its just not safe.
lol i did. I talked about them in a few posts on here. I replaced it with pretty much the same thing. Ordered it from Moeser electronics or something like that.

and plus I tend to just do things and then post about it lol. like 2 ppl from the site knew I was bagging my truck while it was happening.
 

·
Member's Technical crew
Joined
·
12,060 Posts
Well hell, maybe in the future we can save ya some money! And at least you can sell the old alt...or give it away in the for free thread!!


Either way, glad you got her fixed. I had to push the truck once...WAS NOT happy about it!
 
Good to know...

I got a similar error on my DIC when I had an internal alternator failure occur. One of the rotor arms in the unit cracked and was shorting to the case when spun up at mid/high revs, sending a HUGE charge through the system. I hooked up a voltmeter to see what was going on when I revved over 4k that was causing the DIC error and it'd spike over 22 volts. Oops. I'm lucky I didn't fry the entire truck's wiring.
 

·
Texas Yoda!!!!
Joined
·
36,263 Posts
How about...POST UP when your having ALL those issues friend. That way we could have told you BEFORE you did this to check the damn fuse! LOL had this EXACT problem on Diminoe's truck He said he tested all the fuses before I ever started..lol. After a new alt was installed and teh problem persisted i checked the damn things myself! Guess whut...mega fuse was bad. Imagine the look on HIS face...Wish I would have had a camera!! He was like oh shit! This guy is gonna be pissed! LOL I wasnt of course, but it's one of those stories you look back on and laugh.

BTW, you didn't happen to replace your fuse with one from autozone or advance did you? I looked and he looked, and the only one's we found were of higher amp rating than the 100 amp from factory. I would NOT suggest going with the higher amperage fuse as its just not safe.
you kill me with you life lessons :lol:
imma call you Dr. 355phil!



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 

·
Premium Member
Joined
·
219 Posts
so which mega fuze am I needing to get and where does it go, I guess these problems were happening while I was deployed and I just got back and getting the chargsys code on the dic so wanting to know this easy fix
 

·
Bagged Bomber
Joined
·
10,954 Posts
Discussion Starter #10
If you look at your fuse box its the gigantic fuse where the power comes in.



Its that big fuse on the very left of the fuse box. It says 100 on it.
 

·
Registered
Joined
·
1 Posts
Just wanted to make a post for anyone who has this issue ion the future.

I took my truck to the store the other day. When I tried to leave I I got an ABS light on the dash. Shut the truck off to see if it would go away and it would not restart. Its happened before so I knew If I just waited a bit it would restart. Got it restarted and get going home and the music was surging in and out over the radio, shut that off. The engine also started to die out but if I goosed it it would get going again. If I turned on my compressor the engine would bog WAY down. I wasnt far from home and when I made my last turn into my neighbor hood it shut all the way down. So I push it the rest of the way home It wasnt but a block no big deal.

Anyway I figured its probably my alt or battery so I pull them off and have the battery checked at vatozone but they couldnt check the alt so they sent me somewhere else. The battery said it was at 44% charge but they said we'd ahve to charge it to see if it would hold a charge. That got forgot about in the fuss to find a place that could actually test it. got the alt checked and it came back bad. FUCK. I go to a junkyard and get a new on.... doesnt fix the problem. Notice my battery was kindof bulging so I say fuck it and go buy a new one.... that doesnt fix it either FML.

I talked to supermod and he told me it was probably the battery control module. Call teh dealership and thats $87. found another thread on here that said they had similar issues and fixed it by changing the mega fuse.... $5 part...

I ordered the mega fuse cause Id rather try that then waste anouther $90 and TADAH that fixed it.

SO long story short if you truck dies and you have the "service chargsys" on your DIC try replacing your mega fuse first. Dont be a dub fuck and waste a bunch of money like me.
Yall make this mechanicin stuff easy...lol.

Question tho..... when your engine bogged down and light came on... did you have an issue with the heat/air stop blowing. . Randomly shutting off and then bk on again?
 
1 - 11 of 11 Posts
Top