Chevrolet Colorado & GMC Canyon Forum banner

1 - 20 of 34 Posts

·
Registered
Joined
·
893 Posts
Discussion Starter #1
So today I'm leaving work, I turned out of the parking lot and started to hit the brakes to slow for the yield sign. When I applied the brakes at say 20 mph the truck went CRAZY!!! It was shuddering like the ABS was applied and pulled so hard to the right it almost ripped the wheel out of my hand. Naturally I was like WTF??? So I continued about 100 ft or so and applied the brakes again same thing happened. So I pulled over, shut the truck off, looked around at everything I could think of, everything looked fine. So I started it back up and when I did I had the ABS light on, the parking brake light on and the DIC was flashing ABS, Fault, Brakes. So I tried to move it and everything seemed fine and stopped just fine. So I called the dealership and they said that I could drive it and it's just my ABS would not work. So I drove her straight to the dealer and that's where she'll sit till tomorrow.

Anyone know what it might be?????????
 

·
Registered
Joined
·
466 Posts
ABS Sensors? :shrug:
 

·
Registered
Joined
·
577 Posts
mine has done that except for the wheel turning right. it just started abs goin 40 and then it returned to normal. this was in the summer on blacktop. it works right now though on the ice
 

·
Registered
Joined
·
1,446 Posts
my 04 did the samething it was the right hub assemble. i all most hit someone the first time it happened. hope they get it fixed
 

·
Registered
Joined
·
893 Posts
Discussion Starter #7
Well I hope it's an easy fix.........

The main thing I'm worried about is the wheels, drop, etc, etc. It seems that they always have a way out and end up charging you.
 

·
Registered
Joined
·
5,090 Posts
Well I hope it's an easy fix.........

The main thing I'm worried about is the wheels, drop, etc, etc. It seems that they always have a way out and end up charging you.
no shit. "you lowering your truck caused the radio not to be able to read mp3's..." dumbasses.
 

·
Registered
Joined
·
893 Posts
Discussion Starter #9
Well one things good I'm covered by the extended warranty. But we'll see what they will cover..........
 

·
Registered
Joined
·
667 Posts
Yicks that sucks dude. Good luck with that, let us know if they give you a hard time covering it under warranty.
 

·
Registered
Joined
·
893 Posts
Discussion Starter #12
I sure will.

I haven't heard anything as of yet.
 

·
Registered
Joined
·
893 Posts
Discussion Starter #14
Well I guess luck isn't on my side at all. I'm now driving a 2006 maroon chevy uplander until Monday hopefully!!!

Here's the deal. When I took it in I showed the service lady all the lights that were on and flashing. She noted everything but of course they shut off the truck for the night and low and behold the fucking thing was fine in the morning. There were NO codes to be had anywhere. She said the only thing in the history was a code for a wheel speed sensor but nothing dealing with the ABS or brakes at all.

When I dropped it off I also told them about the temp gage going down under load and returning to normal after the load is removed. When they checked that they found that under load the engine was showing a 20 to 40 degree drop in temp. Which is totally backasswards!!! So now the only thing my baby is getting fixed for is the fucking $53.00 thermostat and housing, well that is after they do more diagnostic tests. Needless to say I'm not very happy so far with this computer age shit! I mean I love my truck but damn, I hate hearing, "Well sir without a code there is nothing showing us what's wrong and what to fix......."
 

·
Registered
Joined
·
893 Posts
Discussion Starter #17
:lol:

With some walmart spinners and some getto tint it'd be smokin!!!
 

·
NW Surfrider
Joined
·
5,364 Posts
haha... yeah i hate the old bullshit of no code....no help... WTF... whatever happended to a good old mechanic which will listen to what you are saying and diagnose from there... that why my old mechanic was an old guy, who knew everything about cars...and said fuck computers...
 

·
Registered
Joined
·
430 Posts
But if there was a speed sensor fault that would throw your ABS all off as well. If the ABS unit doesnt know how fast a wheel is going it would most likely have the same problem that you described. I would think they should be replacing that speed sensor as well.
 
1 - 20 of 34 Posts
Top