Chevrolet Colorado & GMC Canyon Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
3.5 I5 4x4 chevy 178k miles ... Hoping you guys can help.. The truck starts fine in the morning or after it cools down for an hr or two:ugh:,, but wont start back up while hot, seems as if its not getting enough gas or something it also stays at high temp four lines above the midpoint all time never over heats, not sure if the thermostat was change.
 

·
Nation Lurker
Joined
·
799 Posts
Check your starter. A bad starter will not crank when hot. How to Test a Starter Solenoid: 4 Steps - wikiHow

Check to see if the water pump is working. You can tell if the water pump is working by removing the radiator cap with the engine COLD, start it up keep a bucket under the radiator it can get a lil messy. run it til the thermostat opens , you should see the water start flowing thru the system. if you dont & it starts to over heat then your thermostat is not opening. once the engine gets hot put the cap back on before you shut it off . if you shut it off with the cap openned anti freeze will fly out , so be careful.
 

·
Premium Member
Joined
·
670 Posts
If you're running at almost three quarter temp gauge you may want to fix that problem first because a thermostat or thermo-sensor etc. may have an impact on your hot start issue.
 

·
Registered
Joined
·
1,061 Posts
Put fuel pressure gauge on it you know it acts up and won't start. Do a search for your temp gauge reading. You will find that interesting . Is the gauge at cold after it sits all night?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
Thanks will do so and keep you posted, I was told if the thermostat was change it would run high, not sure how true that is or if it was changed
 

·
Registered
Joined
·
1,061 Posts
The temp gauge seems normal then. The fuel pressure test cold vs hot (when it will not start) will rule out or help discover a fueling problem. Were not supposed to run out of gas with these efi setup motors its not good for them.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #13
so left the truck with the mechanic and it acted up with them and they still cant find the issue. not sure what to do
 

·
Registered
Joined
·
1,104 Posts
resurrecting an old thread, im having the same probem, maybe slightly worse, the truck has died on me twice at a light... my fuel pump is new, maf is 7 months old as well as map sensor and spark plugs... im not getting any codes.

OP ever find a fix to this_?
 

·
Registered
Joined
·
1,104 Posts
it ended up being my fuse box in need of a good cleaning..
 
1 - 15 of 15 Posts
Top