Chevrolet Colorado & GMC Canyon Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
471 Posts
Discussion Starter #1
My right TYC LED tailight "flickers" ever now and again. If I hit the brakes, it stops. It also does not blink when I hit the keyless entry (the left one does). I've checked the connection and it's fine. Has anyone else had this issue?
 

·
Registered
Joined
·
84 Posts
It's probably a cold solder joint somewhere. Either that or a loose connection. If you can, I'd have it replaced by whoever sold it to you.
 

·
Registered
Joined
·
1,996 Posts
It's probably a cold solder joint somewhere. Either that or a loose connection. If you can, I'd have it replaced by whoever sold it to you.
Just an idea, but if this is the case and you know how to solder then taking it apart yourself and doing it will probably be much easier/quicker than arguing with the seller, boxing it up, shipping it out and waiting for it to come back.
 

·
Registered
Joined
·
84 Posts
Just an idea, but if this is the case and you know how to solder then taking it apart yourself and doing it will probably be much easier/quicker than arguing with the seller, boxing it up, shipping it out and waiting for it to come back.
And not a bad idea - if you know how to solder. But that is what I'd do. I see a lot of LED stoplights with the same issue. It's annoying as hell at night.
 

·
Registered
Joined
·
1,996 Posts
And not a bad idea - if you know how to solder. But that is what I'd do. I see a lot of LED stoplights with the same issue. It's annoying as hell at night.
Agreed, I was behind a guy in an SUV (forget what kind) the other day that every time he'd step on the brake, his third brake light would fucking strobe for 5 seconds and then light up solid. Got annoying as hell because when we got in traffic he started tapping the brakes every 10 seconds. :mav2:
 

·
Registered
Joined
·
84 Posts
Agreed, I was behind a guy in an SUV (forget what kind) the other day that every time he'd step on the brake, his third brake light would fucking strobe for 5 seconds and then light up solid. Got annoying as hell because when we got in traffic he started tapping the brakes every 10 seconds. :mav2:
He'll end up getting sued by an epileptic...
 

·
Registered
Joined
·
471 Posts
Discussion Starter #8
I bought them from someone off another forum. So shipping them back isn't an option. May have to open them up myself and solder. I'm "OK" with the soder iron :) But like I said, it happens very little and as soon as I hit the brakes it's gone. I may just live with it.....Thanks for the advice guys!
 

·
Registered
Joined
·
471 Posts
Discussion Starter #9
My left one will occasionally not light up for the first flash when I unlock my truck. But I don't have any other issues with them.
Neither will flash on the first one, the left will flash on the second one.
 

·
Registered
Joined
·
84 Posts
I bought them from someone off another forum. So shipping them back isn't an option. May have to open them up myself and solder. I'm "OK" with the soder iron :) But like I said, it happens very little and as soon as I hit the brakes it's gone. I may just live with it.....Thanks for the advice guys!
Did you buy them from James? If so, talk to him - he's a good guy and I'm sure he'll help you out.
 

·
Registered
Joined
·
2,931 Posts
Ok i gotta chime in here. This isn't due to a manufacturing defect this is actually due to a design defect. You aren't the only one having problems with these TYC LED tails. This is why i chose to wait on mine. There's a ton of folks complainin about this to TYC.

And actually DBNissan is working with TYC engineers right now on different versions of these tails wired in different ways. They've been sending him a few sets of tails to try out and he's been in contact with a designer about it. Contact Dan @ youknowhere if you need any more info but right now they havent found a solution as of yet. They're supposedly talkin about changing the design and making the outside of the tails for marker lamps and the center be brakes like the real caddys.
 

·
Registered
Joined
·
471 Posts
Discussion Starter #12
Ok i gotta chime in here. This isn't due to a manufacturing defect this is actually due to a design defect. You aren't the only one having problems with these TYC LED tails. This is why i chose to wait on mine. There's a ton of folks complainin about this to TYC.

And actually DBNissan is working with TYC engineers right now on different versions of these tails wired in different ways. They've been sending him a few sets of tails to try out and he's been in contact with a designer about it. Contact Dan @ youknowhere if you need any more info but right now they havent found a solution as of yet. They're supposedly talkin about changing the design and making the outside of the tails for marker lamps and the center be brakes like the real caddys.
Thanks TB! Wasn't aware that this was an issue with TYC. If I had known I probably would have waited to. :slap:
 

·
Registered
Joined
·
84 Posts
Ok i gotta chime in here. This isn't due to a manufacturing defect this is actually due to a design defect. You aren't the only one having problems with these TYC LED tails. This is why i chose to wait on mine. There's a ton of folks complainin about this to TYC.

And actually DBNissan is working with TYC engineers right now on different versions of these tails wired in different ways. They've been sending him a few sets of tails to try out and he's been in contact with a designer about it. Contact Dan @ youknowhere if you need any more info but right now they havent found a solution as of yet. They're supposedly talkin about changing the design and making the outside of the tails for marker lamps and the center be brakes like the real caddys.
How is that a design defect? A LED is a pretty simple component and shouldn't ever flicker when put together correctly. Unless the design defect is related to the way it hooks up.
 

·
¯\_(ツ)_/¯
Joined
·
5,884 Posts
How is that a design defect? A LED is a pretty simple component and shouldn't ever flicker when put together correctly. Unless the design defect is related to the way it hooks up.
I think that's the problem, in the way it's wired. I think the BCM handles the signals and brake lights in our trucks and it makes things more difficult. :shrug:
 

·
Registered
Joined
·
3,444 Posts
Mine work great... I wish they transistioned from full brake light to the dim night mode a little cleaner... right now mine take about .5 seconds to re-set from every brake tap but honestly... I don't see it so I don't really care :)
 

·
Registered
Joined
·
471 Posts
Discussion Starter #16
Mine work great... I wish they transistioned from full brake light to the dim night mode a little cleaner... right now mine take about .5 seconds to re-set from every brake tap but honestly... I don't see it so I don't really care :)

Mine do the samething. Only reason I know this is I can see them in my neighbor's window when I pull in my garage. But like you said, I don't see it...so "F" it.
 
1 - 16 of 16 Posts
Top