Chevrolet Colorado & GMC Canyon Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
Code popped up on my 04 Colorado, and I found the # to the Ac delco part that was only 30$. Went ahead and ordered it, but received the same looking solenoid except with a different electrical plug in. They sent me - Ac Delco: 214-2324. I emailed ac delco and recieved this email. Sadly there closed today, so until I call I wanted some input on this issue.. anyways here it is..

ACDelco 214-2147 OE Service Vapor Canister Purge Valve [ASIN: B0031IBSDG]

------------- Begin message -------------

Thank you for the email however the part you received is the correct part it has been superceeded by Ac Delco to the new number and will be the same for you. We don't have the other part number available only the new number we have sent you.
 

· Registered
Joined
·
32 Posts
Discussion Starter · #3 ·
Thanks for this! The part they sent me shows only 15$ on amazon. So I wonder if they will be giving me that price instead of the 30$ part that was discontinued. The jumper is 17$ roughly so all in all I came out at the same price. Ordering this part as we speak!
 

· Registered
Joined
·
32 Posts
Discussion Starter · #5 · (Edited)
So I recently got this part replaced thanks to The help of you and 355nation. Today when I started my truck I've never felt such terrible idle.. While on the highway, doing 70, my engine light came on and started blinking. I then realized I was losing speed slowly then all the sudden back to 100% power. Didn't think I was going to make it home.. Scanned my computer and P0446 came up and also a misfire on cylinder 3. When I left my house, kinda furious, I really got on the pedal. Low and behold the engine light goes off. Although the problem is still there. Any ideas on what my next step is..?

Tomorrow should I pull out the charcoal box and clean it out. My vent solenoid previously was horrendously dirty, and the hose also. Could some of that dirt made it's way somewhere it shouldn't be?
As for the misfire.. That coil pack has been replaced within the year, and also the plugs. Maybe it's time to switch too a different plug?
Throttle body and MAF have both been cleaned a month or so back. In looking into getting a ported throttle body and also a tune to help my trucks performance.
 

· Registered
Joined
·
32 Posts
Discussion Starter · #8 ·
I took out the charcoal canister and solenoid, got a new fuel line between them and it seemed to of fixed that code. Also cleaned up the charcoal canister and the inlets the lines snap on. No signs of that code yet.
Took out coil pack #3 and all seemed good. Spark plug seemed fine but a little dirty.
My MAF sensor wasn't seated correctly, so if bet that's what was making my truck idle terribly and also run terribly. Put everything back together and engine light went off within 2 min. Although one problem remains. After about 7 min on idle my truck starts struggling causing the rpms to drop then ramp. Sometimes it can't pick itself back up and stalls.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top