Chevrolet Colorado & GMC Canyon Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I really hope someone can help me. I drive an automatic 2006 z85 colorado i-5 3.5l. Yesterday I was driving around 50 mph and randomly noticed that it was reving much to high to be cruising at 50. so i stopped, turned the vehicle off, and restarted it. I then accelerated like i normally would. It shifted to 2nd gear perfectly fine, but when it tried to shift into 3rd it (Now i'm just saying it "felt" like this now i don't know for certain) slipped into neutral and just kept reving until i slowed back down to second. now, if i pressed down on the gas hard enough it would keep going like normal (I'm guessing it would jump to fourth maybe?) but when i slow back down to third it would do the same slipping feeling and would find the 3rd gear. my transmission fluid is healthy as i checked it today and i just had it changed 1,800 miles ago. there is NO "check engine light" coming on. The truck reverses and locks into park completely normal, in fact everything feels normal when driving accept the third gear not working of course. I don't know what to do or what it could be. some people are saying it could be a sensor malfunction? It just feels like my third gear disappeared.
 

·
Premium Member
Joined
·
3,508 Posts
Could be the 2-3 shift solenoid.
 

·
Registered
Joined
·
266 Posts
Sound like you may want to go to the trans shop and have them test drive it with a scan tool connected. Seems to me the special trick scanner can read the trans info.
Best of luck hope it is cheap and simple for you....
 
1 - 5 of 5 Posts
Top