Chevrolet Colorado & GMC Canyon Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
664 Posts
Discussion Starter #1
Hey guys, Ive searched around for about an hour or two through the search engine on here and google but havent turned up anything. Basically since I got a tune from limeswap i have had an ABS light as well as a low trac light come on each time I start the truck. After talking with Jeremy at limeswap about it he suggested that he thought it was the ABS control module that needed to be replaced. The reasoning he suggested was that since my truck started as a z85 with small tires and it is now lifted with 33s the abs module is reading the wheel speed incorrectly whereas the pcm is reading the now corrected speed (because of the tune). And the difference in the two speeds is throwing everything for a loop. Before the tune I never had any issues with this but my speedometer was somewhere around 25% off which was ridiculous. My question is though has anyone else had this same experience. I would think there would have to be at least more than 1 lifted z85 with a limeswap tune on the entire site but who knows. Also, can anyone speculate on if getting the abs control module out of a z71 (which has larger tires stock opposed to a z85, thus being closer to the size tire that I have now) would fix the issue. Looking to resolve this soon as starting at the lights and clearing the dic constantly is getting old. Thanks guys
 

·
Registered
Joined
·
2,238 Posts
I don't have the answer to your question man but to my knowledge, slicksteveo (slickanddirtymotorsports) is a z85, 33s, with a Limeswap tune. as for his ABS, idk if he still has it even. but just to point you in the direction of some help. good luck brotha.
 

·
Registered
Joined
·
664 Posts
Discussion Starter #3
Thanks for the response doc, If i remember correctly steve doesn't have abs anymore. I could be wrong on that but i seem to remember something like that. As of right now the abs fuse is pulled so I don't have to deal with all the lights and everything.
 

·
Registered
Joined
·
1,408 Posts
steve has no abs lol
 

·
Registered
Joined
·
664 Posts
Discussion Starter #5
Anyone got any ideas on this? I guess what Im really wondering is where does the abs pull its speed calculation from? I would imagine it would be through the control module but im hesitant to spend $200+ for something Im not sure will actually fix the issue
 

·
Registered
Joined
·
664 Posts
Discussion Starter #7
Ill see if I can get a code read out of it but Im not sure the code will tell me whats going on exactly. Like Im almost positive its because the corrected speed in the pcm is not matching up to the wheel speed that the abs system recognizes (since the tires are far bigger than stock) Another example I could think of would be one of you guys that have a z71 running 35s or larger. Have any of those guys had anything close to this after the speedo is corrected?

The main question is where does the abs system calculate its wheel speed? I would assume it would be the abs control module but wanted to make sure before I go buying a 200 dollar part.
 

·
Premium Member
Joined
·
35 Posts
I know this is old but I too am having an abs fault after a limeswap tune. What ever came of this?


Sent from my iPhone using Tapatalk
 
1 - 8 of 8 Posts
Top